# Generat per a:
# RouterOSv3.x
:log info "Unsolclic for 29117-BRGFumanyaST going to be executed."
#
# Configuration for RouterOSv3.x
# Device: 29117-BRGFumanyaST
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
# a.Winbox (with Linux, wine required)
# b.Terminal (telnet, ssh...)
# Then execute the script with:
# > /system script run script_name
# 2.-Fitxer importat:
# Desa aquesta "sortida" a un fitxer, després puja'l al router
# fent servir FTP amb un nom de l'estil "script_name.rsc".
# (note, l'extensió ".rsc" es un requisit)
# Executa el fitxer importat amb la comanda:
# > /import script_name
# 3.-Telnet copia i enganxar:
# Open a terminal session, and cut&paste this output
# directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
# according in how did you connect the cable to the miniPCI. Keep the
# power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
# (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
# to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
# the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=BRGFumanyaST
#
# DNS (client & server cache) zone: 6476
/ip dns set primary-dns=10.138.65.226 secondary-dns=10.138.65.226 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 6476
/system ntp client set enabled=yes mode=unicast primary-ntp=10.228.3.66
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp set contact="guifi@guifi.net" enabled=yes location="BRGFumanya"
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
# Construct main bridge on wlan1 & ether1
/ interface bridge
add name="wLan/Lan"
/ interface bridge port
add interface=ether1 bridge=wLan/Lan
add interface=wlan1 bridge=wLan/Lan
:delay 1
#
# Radio#: 0 BRGFmnyAP1
/interface wireless set wlan1 name="wlan1" \
radio-name="BRGFmnyAP1" mode=ap-bridge ssid="guifi.net-BRGFmnyAP1" \
band="5ghz" \
frequency-mode=regulatory-domain country=spain antenna-gain=10 \
frequency=5200 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan/Lan
/ip address
:foreach i in [find address="10.139.71.1/27"] do={remove $i}
/ ip address add address=10.139.71.1/27 network=10.139.71.0 broadcast=10.139.71.31 interface=wLan/Lan disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.139.71.0/27] do={/routing bgp network remove $i;}
add network=10.139.71.0/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wLan/Lan] do={/routing ospf interface remove $i;}
add interface=wLan/Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.139.71.0/27] do={/routing ospf network remove $i;}
add network=10.139.71.0/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wLan/Lan] do={/ip pool remove $i;}
/ip pool add name=dhcp-wLan/Lan ranges=10.139.71.7-10.139.71.30
:foreach i in [/ip dhcp-server find name=dhcp-wLan/Lan] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wLan/Lan interface=wLan/Lan address-pool=dhcp-wLan/Lan disabled=no
:foreach i in [/ip dhcp-server network find address="10.139.71.0/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.139.71.0/27 gateway=10.139.71.1 domain=guifi.net comment=dhcp-wLan/Lan
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.139.71.2 mac-address=00:15:6D:72:9A:D2 client-id=BRGComellasRd2 server=dhcp-wLan/Lan
add address=10.139.71.3 mac-address=00:15:6D:D8:23:45 client-id=BRGLaPrekariaRd1 server=dhcp-wLan/Lan
add address=10.139.71.4 mac-address=00:15:6D:82:7B:FA client-id=BRGSTGuimRd1 server=dhcp-wLan/Lan
add address=10.139.71.5 mac-address=00:11:22:33:44:56 client-id=BGRcompteoliba42Rd1 server=dhcp-wLan/Lan
add address=10.139.71.6 mac-address=00:27:22:1E:3C:C9 client-id=AVCalVerdumRd1 server=dhcp-wLan/Lan
add address=10.139.71.7 mac-address=00:15:6D:A0:F2:B5 client-id=BRGSantaBarbara19Rd1 server=dhcp-wLan/Lan
add address=10.139.71.9 mac-address=00:27:22:10:D6:78 client-id=BRGCrvnts23Rd1 server=dhcp-wLan/Lan
add address=10.139.71.11 mac-address=00:15:6D:A0:EA:ED client-id=BRGPacoRd1 server=dhcp-wLan/Lan
add address=10.139.71.12 mac-address=00:15:6D:E6:8E:57 client-id=BRGmdBoscRd1 server=dhcp-wLan/Lan
add address=10.139.71.13 mac-address=00:27:22:14:9A:42 client-id=BRGQueraltRd4 server=dhcp-wLan/Lan
add address=10.139.71.14 mac-address=00:27:22:40:B4:44 client-id=BRGmtibarRd1 server=dhcp-wLan/Lan
add address=10.139.71.15 mac-address=24:A4:3C:76:69:54 client-id=BRGSantFruitos36Rd1 server=dhcp-wLan/Lan
#
:delay 1
# Type: wds/p2p
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether3] do={/routing ospf interface remove $i;}
add interface=ether3
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.42.152/30] do={/routing ospf network remove $i;}
add network=172.25.42.152/30 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BRGFumanyaSwitch] do={/routing bgp peer remove $i;}
add name="BRGFumanyaSwitch" instance=default remote-address=172.25.42.153 remote-as=30669 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="172.25.42.154/30"] do={/ip address remove $i;}
:delay 1
/ ip address add address=172.25.42.154/30 network=172.25.42.152 broadcast=172.25.42.155 interface=ether3 disabled=no comment="BRGFumanyaSwitch"
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.139.71.1 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.139.71.1" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.139.71.1"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=29117 router-id=10.139.71.1 \
redistribute-connected=yes redistribute-static=yes redistribute-rip=yes \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf set router-id=10.139.71.1 distribute-default=never redistribute-connected=no \
redistribute-static=no redistribute-rip=no redistribute-bgp=as-type-1
#
:log info "Unsolclic for 29117-BRGFumanyaST executed."
/