# Generat per a:
# RouterOSv6.x
:log info "Unsolclic for 29851-BCNFabraiPuig313-RB2011 going to be executed."
#
# Configuration for RouterOSv6.x
# Trasto: 29851-BCNFabraiPuig313-RB2011
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
# a.Winbox (with Linux, wine required)
# b.Terminal (telnet, ssh...)
# Then execute the script with:
# > /system script run script_name
# 2.-Fitxer importat:
# Desa aquesta "sortida" a un fitxer, després puja'l al router
# fent servir FTP amb un nom de l'estil "script_name.rsc".
# (note, l'extensió ".rsc" es un requisit)
# Executa el fitxer importat amb la comanda:
# > /import script_name
# 3.-Telnet copia i enganxar:
# Open a terminal session, and cut&paste this output
# directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
# according in how did you connect the cable to the miniPCI. Keep the
# power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
# (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
# to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
# the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=BCNFabraiPuig313-RB2011
#
# DNS (client & server cache) zone: 2436
/ip dns set servers=10.228.203.104,10.139.94.98 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 2436
/system ntp client set enabled=yes mode=unicast primary-ntp=10.228.203.104 secondary-ntp=10.228.192.212
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="BCNFabraiPuig313" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
:delay 1
#
# Radio#: 0 BCNxsfcoopCarmelST1
/interface wireless set wlan1 name="wlan1" \
radio-name="BCNxsfcoopCarmelST1" mode=ap-bridge ssid="guifi.net-BCNxsfcoopCarmelST1" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=5580 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsBCNxsfcoopCarmelST1
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_BCNxsfcoopCarmelR1" master-interface=wlan1 wds-address=FA:BA:DA:FA:BA:DA disabled=no
/ ip address add address=172.25.65.42/29 network=172.25.65.40 broadcast=172.25.65.47 interface=wds_BCNxsfcoopCarmelR1 disabled=no comment="wds_BCNxsfcoopCarmelR1"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_BCNxsfcoopCarmelR1] do={/routing ospf interface remove $i;}
add interface=wds_BCNxsfcoopCarmelR1
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.65.40/29] do={/routing ospf network remove $i;}
add network=172.25.65.40/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BCNxsfcoopCarmelR1] do={/routing bgp peer remove $i;}
add name="BCNxsfcoopCarmelR1" instance=default remote-address=172.25.65.41 remote-as=51471 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
#
:delay 1
#
# Radio#: 1 BCNFabraiPuig313-AP0
/interface wireless set wlan2 name="wlan2" \
radio-name="BCNFabraiPuig313-AP0" mode=ap-bridge ssid="guifi.net-BCNFabraiPuig313-AP0" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=16 \
frequency=5280 \
dfs-mode=none \
antenna-mode=ant-b wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsBCNFabraiPuig313-AP0
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan2] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_BCNcartella75RB450G" master-interface=wlan2 wds-address=00:00:00:00:00:00 disabled=no
/ ip address add address=172.30.8.101/29 network=172.30.8.96 broadcast=172.30.8.103 interface=wds_BCNcartella75RB450G disabled=no comment="wds_BCNcartella75RB450G"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_BCNcartella75RB450G] do={/routing ospf interface remove $i;}
add interface=wds_BCNcartella75RB450G
/ routing ospf network
:foreach i in [/routing ospf network find network=172.30.8.96/29] do={/routing ospf network remove $i;}
add network=172.30.8.96/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BCNcartella75RB450G] do={/routing bgp peer remove $i;}
add name="BCNcartella75RB450G" instance=default remote-address=172.30.8.100 remote-as=41382 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
#
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.139.88.33/27"] do={remove $i}
/ ip address add address=10.139.88.33/27 network=10.139.88.32 broadcast=10.139.88.63 interface=wlan2 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.139.88.32/27] do={/routing bgp network remove $i;}
add network=10.139.88.32/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan2] do={/routing ospf interface remove $i;}
add interface=wlan2
/ routing ospf network
:foreach i in [/routing ospf network find network=10.139.88.32/27] do={/routing ospf network remove $i;}
add network=10.139.88.32/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan2] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan2 ranges=10.139.88.39-10.139.88.62
:foreach i in [/ip dhcp-server find name=dhcp-wlan2] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan2 interface=wlan2 address-pool=dhcp-wlan2 disabled=no
:foreach i in [/ip dhcp-server network find address="10.139.88.32/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.139.88.32/27 gateway=10.139.88.33 domain=guifi.net comment=dhcp-wlan2
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.139.88.34 mac-address=00:15:6D:D0:1A:53 client-id=BCNEscultorLimona8bRd1 server=dhcp-wlan2
add address=10.139.88.35 mac-address=DC:9F:DB:44:77:EF client-id=BCNflp240Rd1 server=dhcp-wlan2
add address=10.139.88.36 mac-address=00:00:00:00:00:00 client-id=BCNEscoltorLlimona43Rd1 server=dhcp-wlan2
add address=10.139.88.37 mac-address=FC:EC:DA:0A:06:DF client-id=BCNagudells78Rd1 server=dhcp-wlan2
add address=10.139.88.38 mac-address=00:C0:CA:93:4A:E2 client-id=BCNSanpereiMiquel2Rd1 server=dhcp-wlan2
#
:delay 1
#
# Radio#: 2 FiP313-Agudells37
/interface wireless set wlan3 name="wlan3" \
radio-name="FiP313-Agudells37" mode=ap-bridge ssid="guifi.net-FiP313-Agudells37" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=23 \
frequency=5680 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsBCNFabraiPuig313-Agudells37
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan3] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_BCNAgudells37Rd1" master-interface=wlan3 wds-address=00:27:22:A0:61:A2 disabled=no
/ ip address add address=172.25.47.156/29 network=172.25.47.152 broadcast=172.25.47.159 interface=wds_BCNAgudells37Rd1 disabled=no comment="wds_BCNAgudells37Rd1"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_BCNAgudells37Rd1] do={/routing ospf interface remove $i;}
add interface=wds_BCNAgudells37Rd1
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.47.152/29] do={/routing ospf network remove $i;}
add network=172.25.47.152/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BCNAgudells37Rd1] do={/routing bgp peer remove $i;}
add name="BCNAgudells37Rd1" instance=default remote-address=172.25.47.153 remote-as=46821 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
#
:delay 1
#
# Radio#: 3 FiP313-BCNLorda17
/interface wireless set wlan4 name="wlan4" \
radio-name="FiP313-BCNLorda17" mode=ap-bridge ssid="guifi.net-FiP313-BCNLorda17" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=5600 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsBCNFabraiPuig313-BCNLorda17
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan4] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_BCNLorda17CC1009RB" master-interface=wlan4 wds-address=00:27:22:A8:D5:D5 disabled=no
/ ip address add address=172.25.48.25/29 network=172.25.48.24 broadcast=172.25.48.31 interface=wds_BCNLorda17CC1009RB disabled=no comment="wds_BCNLorda17CC1009RB"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_BCNLorda17CC1009RB] do={/routing ospf interface remove $i;}
add interface=wds_BCNLorda17CC1009RB
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.48.24/29] do={/routing ospf network remove $i;}
add network=172.25.48.24/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BCNLorda17CC1009RB] do={/routing bgp peer remove $i;}
add name="BCNLorda17CC1009RB" instance=default remote-address=172.25.48.28 remote-as=38506 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.139.90.192/29] do={/routing ospf network remove $i;}
add network=10.139.90.192/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BCNFabraiPuig313Crml] do={/routing bgp peer remove $i;}
add name="BCNFabraiPuig313Crml" instance=default remote-address=10.139.90.194 remote-as=32724 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.139.90.192/29] do={/routing ospf network remove $i;}
add network=10.139.90.192/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BCNFabraiPuig313Agudells] do={/routing bgp peer remove $i;}
add name="BCNFabraiPuig313Agudells" instance=default remote-address=10.139.90.196 remote-as=34255 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.139.90.192/29] do={/routing ospf network remove $i;}
add network=10.139.90.192/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BCNFabraiPuig313Lorda] do={/routing bgp peer remove $i;}
add name="BCNFabraiPuig313Lorda" instance=default remote-address=10.139.90.197 remote-as=34260 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.139.90.192/29] do={/routing ospf network remove $i;}
add network=10.139.90.192/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BCNFabraiPuig313ROCKET1] do={/routing bgp peer remove $i;}
add name="BCNFabraiPuig313ROCKET1" instance=default remote-address=10.139.90.195 remote-as=34254 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="10.139.90.193/29"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.139.90.193/29 network=10.139.90.192 broadcast=10.139.90.199 interface=Lan disabled=no comment="BCNFabraiPuig313Crml,BCNFabraiPuig313Agudells,BCNFabraiPuig313Lorda,BCNFabraiPuig313ROCKET1"
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.139.88.33 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.139.88.33" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.139.88.33"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=29851 router-id=10.139.88.33 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf instance set default name=default router-id=10.139.88.33 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 29851-BCNFabraiPuig313-RB2011 executed."
/