# Generat per a:
# RouterOSv5.x
:log info "Unsolclic for 38531-VRStLucia167Rd1 going to be executed."
#
# Configuration for RouterOSv5.x
# Trasto: 38531-VRStLucia167Rd1
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
#     a.Winbox (with Linux, wine required)
#     b.Terminal (telnet, ssh...)
#    Then execute the script with:
#      > /system script run script_name
# 2.-Fitxer importat:
#     Desa aquesta "sortida" a un fitxer, després puja'l al router
#     fent servir FTP amb un nom de l'estil "script_name.rsc".
#     (note, l'extensió ".rsc" es un requisit)
#     Executa el fitxer importat amb la comanda:
#      > /import script_name
# 3.-Telnet copia i enganxar:
#     Open a terminal session, and cut&paste this output
#     directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
#   according in how did you connect the cable to the miniPCI. Keep the
#   power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
#   (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
#   to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
#   the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=VRStLucia167Rd1
#
# DNS (client & server cache) zone: 18900
/ip dns set servers=10.228.130.162 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 18900
/system ntp client set enabled=yes mode=unicast primary-ntp=10.228.130.162
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="VRStLucia167" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
:delay 1
#
# Radio#: 0 VRStLucia167-AP0-omni
/interface wireless set wlan1 name="wlan1" \
radio-name="VRStLucia167-AP0-omni" mode=ap-bridge ssid="guifi.net-VRStLucia167-AP0-omni" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=26 \
frequency=5560 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.90.75.161/27"] do={remove $i}
/ ip address add address=10.90.75.161/27 network=10.90.75.160 broadcast=10.90.75.191 interface=wlan1 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.90.75.160/27] do={/routing bgp network remove $i;}
add network=10.90.75.160/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan1] do={/routing ospf interface remove $i;}
add interface=wlan1
/ routing ospf network
:foreach i in [/routing ospf network find network=10.90.75.160/27] do={/routing ospf network remove $i;}
add network=10.90.75.160/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan1] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan1 ranges=10.90.75.167-10.90.75.190
:foreach i in [/ip dhcp-server find name=dhcp-wlan1] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan1 interface=wlan1 address-pool=dhcp-wlan1 disabled=no
:foreach i in [/ip dhcp-server network find address="10.90.75.160/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.90.75.160/27 gateway=10.90.75.161 domain=guifi.net comment=dhcp-wlan1
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.90.75.162 mac-address=00:27:22:3E:34:C4 client-id=VRBertomeu76Rd1 server=dhcp-wlan1
add address=10.90.75.163 mac-address=00:00:00:00:00:00 client-id=VilCronistaTraver42Rd1 server=dhcp-wlan1
add address=10.90.75.164 mac-address=00:00:00:00:00:00 client-id=VilVicenteSanchiz24Rd1 server=dhcp-wlan1
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether2] do={/routing ospf interface remove $i;}
add interface=ether2
/ routing ospf network
:foreach i in [/routing ospf network find network=10.90.74.136/29] do={/routing ospf network remove $i;}
add network=10.90.74.136/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=VRStLucia167T0182] do={/routing bgp peer remove $i;}
add name="VRStLucia167T0182" instance=default remote-address=10.90.74.138 remote-as=38666 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="10.90.74.137/29"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.90.74.137/29 network=10.90.74.136 broadcast=10.90.74.143 interface=ether2 disabled=no comment="VRStLucia167T0182"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether1] do={/routing ospf interface remove $i;}
add interface=ether1
/ routing ospf network
:foreach i in [/routing ospf network find network=10.90.74.32/29] do={/routing ospf network remove $i;}
add network=10.90.74.32/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=VRStLucia167Srvr1] do={/routing bgp peer remove $i;}
add name="VRStLucia167Srvr1" instance=default remote-address=10.90.74.33 remote-as=70348 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="10.90.74.34/29"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.90.74.34/29 network=10.90.74.32 broadcast=10.90.74.39 interface=ether1 disabled=no comment="VRStLucia167Srvr1"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether3] do={/routing ospf interface remove $i;}
add interface=ether3
/ routing ospf network
:foreach i in [/routing ospf network find network=10.90.74.152/29] do={/routing ospf network remove $i;}
add network=10.90.74.152/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=VRStLucia167T1256] do={/routing bgp peer remove $i;}
add name="VRStLucia167T1256" instance=default remote-address=10.90.74.154 remote-as=66109 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="10.90.74.153/29"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.90.74.153/29 network=10.90.74.152 broadcast=10.90.74.159 interface=ether3 disabled=no comment="VRStLucia167T1256"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether4] do={/routing ospf interface remove $i;}
add interface=ether4
/ routing ospf network
:foreach i in [/routing ospf network find network=10.90.75.112/29] do={/routing ospf network remove $i;}
add network=10.90.75.112/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=VRStLucia167T2096] do={/routing bgp peer remove $i;}
add name="VRStLucia167T2096" instance=default remote-address=10.90.75.114 remote-as=69886 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="10.90.75.113/29"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.90.75.113/29 network=10.90.75.112 broadcast=10.90.75.119 interface=ether4 disabled=no comment="VRStLucia167T2096"
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.90.75.161 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.90.75.161" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.90.75.161"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=38531 router-id=10.90.75.161 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf instance set default name=default router-id=10.90.75.161 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 38531-VRStLucia167Rd1 executed."
/