# Generat per a:
# RouterOSv6.x
:log info "Unsolclic for 44934-BNCLAlfonsoXIIIRB2011 going to be executed."
#
# Configuration for RouterOSv6.x
# Device: 44934-BNCLAlfonsoXIIIRB2011
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
#     a.Winbox (with Linux, wine required)
#     b.Terminal (telnet, ssh...)
#    Then execute the script with:
#      > /system script run script_name
# 2.-Fitxer importat:
#     Desa aquesta "sortida" a un fitxer, després puja'l al router
#     fent servir FTP amb un nom de l'estil "script_name.rsc".
#     (note, l'extensió ".rsc" es un requisit)
#     Executa el fitxer importat amb la comanda:
#      > /import script_name
# 3.-Telnet copia i enganxar:
#     Open a terminal session, and cut&paste this output
#     directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
#   according in how did you connect the cable to the miniPCI. Keep the
#   power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
#   (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
#   to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
#   the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=BNCLAlfonsoXIIIRB2011
#
# DNS (client & server cache) zone: 18762
/ip dns set servers=10.229.61.3,10.228.130.162 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 18762
/system ntp client set enabled=yes mode=unicast primary-ntp=10.229.62.65 secondary-ntp=10.228.130.162
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="BNCLAlfonsoXIII" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
:delay 1
#
# Radio#: 0 BNCLAlfonsoXIIIRB2011
/interface wireless set wlan1 name="wlan1" \
radio-name="BNCLAlfonsoXIIIRB2011" mode=ap-bridge ssid="guifi.net-BNCLAlfonsoXIIIRB2011" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsBNCLAlfonsoXIIIAP0
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-] do={/ip pool remove $i;}
/ip pool add name=dhcp- ranges=0.0.0.0-
:foreach i in [/ip dhcp-server find name=dhcp-] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp- interface= address-pool=dhcp- disabled=yes
:foreach i in [/ip dhcp-server network find address="/0"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=/0 gateway= domain=guifi.net comment=dhcp-
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
#
:delay 1
# Type: other
/ip address
:foreach i in [find address="10.90.65.225/27"] do={remove $i}
/ ip address add address=10.90.65.225/27 network=10.90.65.224 broadcast=10.90.65.255 interface=wlan1 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.90.65.224/27] do={/routing bgp network remove $i;}
add network=10.90.65.224/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan1] do={/routing ospf interface remove $i;}
add interface=wlan1
/ routing ospf network
:foreach i in [/routing ospf network find network=10.90.65.224/27] do={/routing ospf network remove $i;}
add network=10.90.65.224/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan1] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan1 ranges=10.90.65.231-10.90.65.254
:foreach i in [/ip dhcp-server find name=dhcp-wlan1] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan1 interface=wlan1 address-pool=dhcp-wlan1 disabled=no
:foreach i in [/ip dhcp-server network find address="10.90.65.224/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.90.65.224/27 gateway=10.90.65.225 domain=guifi.net comment=dhcp-wlan1
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.90.65.226 mac-address=99:99:99:99:99:99 client-id=BNCLAlfonsoXIIICatalunya server=dhcp-wlan1
add address=10.90.65.228 mac-address=00:00:00:00:00:00 client-id=BNCLAlfonsoXIIICdpPtP server=dhcp-wlan1
add address=10.90.65.230 mac-address=00:00:00:00:00:00 client-id=BNCLAlfonsoXIIIBNCLCentroHipicoBNCL server=dhcp-wlan1
#
:delay 1
#
# Radio#: 1 BNCLAlfonsoXIIIEuropa
/interface wireless set wlan2 name="wlan2" \
radio-name="BNCLAlfonsoXIIIEuropa" mode=ap-bridge ssid="guifi.net-BNCLAlfonsoXIIIEuropa" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsBNCLAlfonsoXIIIEuropa
/ip address
:foreach i in [find address="172.16.8.59/29"] do={remove $i}
/ ip address add address=172.16.8.59/29 network=172.16.8.56 broadcast=172.16.8.63 interface=wlan2 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=172.16.8.56/29] do={/routing bgp network remove $i;}
add network=172.16.8.56/29 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan2] do={/routing ospf interface remove $i;}
add interface=wlan2
/ routing ospf network
:foreach i in [/routing ospf network find network=172.16.8.56/29] do={/routing ospf network remove $i;}
add network=172.16.8.56/29 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan2] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan2 ranges=172.16.8.62-172.16.8.62
:foreach i in [/ip dhcp-server find name=dhcp-wlan2] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan2 interface=wlan2 address-pool=dhcp-wlan2 disabled=yes
:foreach i in [/ip dhcp-server network find address="172.16.8.56/29"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=172.16.8.56/29 gateway=172.16.8.57 domain=guifi.net comment=dhcp-wlan2
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=172.16.8.57 mac-address=00:00:00:00:00:00 client-id=VNRColoniaEuropaRB2011 server=dhcp-wlan2
#
:delay 1
# Type: wLan
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan2] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan2 ranges=172.16.8.62-172.16.8.62
:foreach i in [/ip dhcp-server find name=dhcp-wlan2] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan2 interface=wlan2 address-pool=dhcp-wlan2 disabled=yes
:foreach i in [/ip dhcp-server network find address="172.16.8.56/29"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=172.16.8.56/29 gateway=172.16.8.57 domain=guifi.net comment=dhcp-wlan2
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=172.16.8.57 mac-address=00:00:00:00:00:00 client-id=VNRColoniaEuropaRB2011 server=dhcp-wlan2
#
:delay 1
#
# Radio#: 2 BNCLAlfonsoXIIICampana
/interface wireless set wlan3 name="wlan3" \
radio-name="BNCLAlfonsoXIIICampana" mode=ap-bridge ssid="guifi.net-BNCLAlfonsoXIIICampana" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=5180 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsBNCLAlfonsoXIIICampana
/ip address
:foreach i in [find address="172.16.13.14/29"] do={remove $i}
/ ip address add address=172.16.13.14/29 network=172.16.13.8 broadcast=172.16.13.15 interface=wlan3 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=172.16.13.8/29] do={/routing bgp network remove $i;}
add network=172.16.13.8/29 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan3] do={/routing ospf interface remove $i;}
add interface=wlan3
/ routing ospf network
:foreach i in [/routing ospf network find network=172.16.13.8/29] do={/routing ospf network remove $i;}
add network=172.16.13.8/29 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan3] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan3 ranges=172.16.13.14-172.16.13.14
:foreach i in [/ip dhcp-server find name=dhcp-wlan3] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan3 interface=wlan3 address-pool=dhcp-wlan3 disabled=yes
:foreach i in [/ip dhcp-server network find address="172.16.13.8/29"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=172.16.13.8/29 gateway=172.16.13.9 domain=guifi.net comment=dhcp-wlan3
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=172.16.13.9 mac-address=00:00:00:00:00:00 client-id=BNCLcampanarRB1100AH server=dhcp-wlan3
#
:delay 1
#
# Radio#: 3 BNCLAlfonsoXIIIAvCS
/interface wireless set wlan4 name="wlan4" \
radio-name="BNCLAlfonsoXIIIAvCS" mode=ap-bridge ssid="guifi.net-BNCLAlfonsoXIIIAvCS" \
band="2ghz-b" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsBNCLAlfonsoXIIIAvCS
/ip address
:foreach i in [find address="172.16.14.34/29"] do={remove $i}
/ ip address add address=172.16.14.34/29 network=172.16.14.32 broadcast=172.16.14.39 interface=wlan4 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=172.16.14.32/29] do={/routing bgp network remove $i;}
add network=172.16.14.32/29 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan4] do={/routing ospf interface remove $i;}
add interface=wlan4
/ routing ospf network
:foreach i in [/routing ospf network find network=172.16.14.32/29] do={/routing ospf network remove $i;}
add network=172.16.14.32/29 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan4] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan4 ranges=172.16.14.38-172.16.14.38
:foreach i in [/ip dhcp-server find name=dhcp-wlan4] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan4 interface=wlan4 address-pool=dhcp-wlan4 disabled=yes
:foreach i in [/ip dhcp-server network find address="172.16.14.32/29"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=172.16.14.32/29 gateway=172.16.14.33 domain=guifi.net comment=dhcp-wlan4
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=172.16.14.33 mac-address=00:00:00:00:00:00 client-id=VNRAvCastelloRB2011 server=dhcp-wlan4
#
:delay 1
#
# Radio#: 4 BNCLAlfXIIISectorOest
/interface wireless set wlan5 name="wlan5" \
radio-name="BNCLAlfXIIISectorOest" mode=ap-bridge ssid="guifi.net-BNCLAlfXIIISectorOest" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.229.43.1/27"] do={remove $i}
/ ip address add address=10.229.43.1/27 network=10.229.43.0 broadcast=10.229.43.31 interface=wlan5 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.229.43.0/27] do={/routing bgp network remove $i;}
add network=10.229.43.0/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan5] do={/routing ospf interface remove $i;}
add interface=wlan5
/ routing ospf network
:foreach i in [/routing ospf network find network=10.229.43.0/27] do={/routing ospf network remove $i;}
add network=10.229.43.0/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan5] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan5 ranges=10.229.43.7-10.229.43.30
:foreach i in [/ip dhcp-server find name=dhcp-wlan5] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan5 interface=wlan5 address-pool=dhcp-wlan5 disabled=no
:foreach i in [/ip dhcp-server network find address="10.229.43.0/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.229.43.0/27 gateway=10.229.43.1 domain=guifi.net comment=dhcp-wlan5
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
#
:delay 1
#
# Radio#: 5 BNCLAlfXIIISectorSud
/interface wireless set wlan6 name="wlan6" \
radio-name="BNCLAlfXIIISectorSud" mode=ap-bridge ssid="guifi.net-BNCLAlfXIIISectorSud" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.229.43.33/27"] do={remove $i}
/ ip address add address=10.229.43.33/27 network=10.229.43.32 broadcast=10.229.43.63 interface=wlan6 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.229.43.32/27] do={/routing bgp network remove $i;}
add network=10.229.43.32/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan6] do={/routing ospf interface remove $i;}
add interface=wlan6
/ routing ospf network
:foreach i in [/routing ospf network find network=10.229.43.32/27] do={/routing ospf network remove $i;}
add network=10.229.43.32/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan6] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan6 ranges=10.229.43.39-10.229.43.62
:foreach i in [/ip dhcp-server find name=dhcp-wlan6] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan6 interface=wlan6 address-pool=dhcp-wlan6 disabled=no
:foreach i in [/ip dhcp-server network find address="10.229.43.32/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.229.43.32/27 gateway=10.229.43.33 domain=guifi.net comment=dhcp-wlan6
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.229.43.34 mac-address=00:00:00:00:00:00 client-id=BNCLSegle5CPE server=dhcp-wlan6
#
:delay 1
#
# Radio#: 6 BNCLAlfXIIISectorNord
/interface wireless set wlan7 name="wlan7" \
radio-name="BNCLAlfXIIISectorNord" mode=ap-bridge ssid="guifi.net-BNCLAlfXIIISectorNord" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=5180 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.229.43.65/27"] do={remove $i}
/ ip address add address=10.229.43.65/27 network=10.229.43.64 broadcast=10.229.43.95 interface=wlan7 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.229.43.64/27] do={/routing bgp network remove $i;}
add network=10.229.43.64/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan7] do={/routing ospf interface remove $i;}
add interface=wlan7
/ routing ospf network
:foreach i in [/routing ospf network find network=10.229.43.64/27] do={/routing ospf network remove $i;}
add network=10.229.43.64/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan7] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan7 ranges=10.229.43.71-10.229.43.94
:foreach i in [/ip dhcp-server find name=dhcp-wlan7] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan7 interface=wlan7 address-pool=dhcp-wlan7 disabled=no
:foreach i in [/ip dhcp-server network find address="10.229.43.64/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.229.43.64/27 gateway=10.229.43.65 domain=guifi.net comment=dhcp-wlan7
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
#
:delay 1
#
# Radio#: 7 BnclAlfonsoXIIICataT1
/interface wireless set wlan8 name="wlan8" \
radio-name="BnclAlfonsoXIIICataT1" mode=ap-bridge ssid="guifi.net-BnclAlfonsoXIIICataT1" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsBnclAlfonsoXIIICataT1
/ip address
:foreach i in [find address="172.16.17.20/29"] do={remove $i}
/ ip address add address=172.16.17.20/29 network=172.16.17.16 broadcast=172.16.17.23 interface=wlan8 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=172.16.17.16/29] do={/routing bgp network remove $i;}
add network=172.16.17.16/29 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan8] do={/routing ospf interface remove $i;}
add interface=wlan8
/ routing ospf network
:foreach i in [/routing ospf network find network=172.16.17.16/29] do={/routing ospf network remove $i;}
add network=172.16.17.16/29 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan8] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan8 ranges=172.16.17.22-172.16.17.22
:foreach i in [/ip dhcp-server find name=dhcp-wlan8] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan8 interface=wlan8 address-pool=dhcp-wlan8 disabled=yes
:foreach i in [/ip dhcp-server network find address="172.16.17.16/29"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=172.16.17.16/29 gateway=172.16.17.17 domain=guifi.net comment=dhcp-wlan8
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=172.16.17.17 mac-address=00:00:00:00:00:00 client-id=BNCLAvCatalunyaRB server=dhcp-wlan8
#
:delay 1
#
# Radio#: 8 BNCLAlfonsoXIIICdpPtP
/interface wireless set wlan9 name="wlan9" \
radio-name="BNCLAlfonsoXIIICdpPtP" mode=ap-bridge ssid="guifi.net-BNCLAlfonsoXIIICdpPtP" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsBNCLCdpAlfonso
/ip address
:foreach i in [find address="172.16.17.44/29"] do={remove $i}
/ ip address add address=172.16.17.44/29 network=172.16.17.40 broadcast=172.16.17.47 interface=wlan9 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=172.16.17.40/29] do={/routing bgp network remove $i;}
add network=172.16.17.40/29 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan9] do={/routing ospf interface remove $i;}
add interface=wlan9
/ routing ospf network
:foreach i in [/routing ospf network find network=172.16.17.40/29] do={/routing ospf network remove $i;}
add network=172.16.17.40/29 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan9] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan9 ranges=172.16.17.46-172.16.17.46
:foreach i in [/ip dhcp-server find name=dhcp-wlan9] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan9 interface=wlan9 address-pool=dhcp-wlan9 disabled=yes
:foreach i in [/ip dhcp-server network find address="172.16.17.40/29"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=172.16.17.40/29 gateway=172.16.17.41 domain=guifi.net comment=dhcp-wlan9
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=172.16.17.41 mac-address=00:00:00:00:00:00 client-id=BNCLcompanyiadelportRB850Gx2 server=dhcp-wlan9
#
:delay 1
#
# Radio#: 9 BNCLAlfXIII-BNCLHipica
/interface wireless set wlan10 name="wlan10" \
radio-name="BNCLAlfXIII-BNCLHipica" mode=ap-bridge ssid="guifi.net-BNCLAlfXIII-BNCLHipica" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
#
# Routed device
#
# Altres connexions de cable
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=SocisCable] do={/routing ospf interface remove $i;}
add interface=SocisCable
/ routing ospf network
:foreach i in [/routing ospf network find network=10.229.42.64/27] do={/routing ospf network remove $i;}
add network=10.229.42.64/27 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BNCLAlfonsoXIIISabi] do={/routing bgp peer remove $i;}
add name="BNCLAlfonsoXIIISabi" instance=default remote-address=10.229.42.66 remote-as=85951 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=SocisCable] do={/routing ospf interface remove $i;}
add interface=SocisCable
/ routing ospf network
:foreach i in [/routing ospf network find network=10.229.42.64/27] do={/routing ospf network remove $i;}
add network=10.229.42.64/27 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BNCLAlfonsoXIIIProp1] do={/routing bgp peer remove $i;}
add name="BNCLAlfonsoXIIIProp1" instance=default remote-address=10.229.42.67 remote-as=85954 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=SocisCable] do={/routing ospf interface remove $i;}
add interface=SocisCable
/ routing ospf network
:foreach i in [/routing ospf network find network=10.229.42.64/27] do={/routing ospf network remove $i;}
add network=10.229.42.64/27 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BNCLAlfonsoXIIIProp2] do={/routing bgp peer remove $i;}
add name="BNCLAlfonsoXIIIProp2" instance=default remote-address=10.229.42.68 remote-as=85956 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=SocisCable] do={/routing ospf interface remove $i;}
add interface=SocisCable
/ routing ospf network
:foreach i in [/routing ospf network find network=10.229.42.64/27] do={/routing ospf network remove $i;}
add network=10.229.42.64/27 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BNCLAlfonsoXIIIProp3] do={/routing bgp peer remove $i;}
add name="BNCLAlfonsoXIIIProp3" instance=default remote-address=10.229.42.69 remote-as=88733 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=SocisCable] do={/routing ospf interface remove $i;}
add interface=SocisCable
/ routing ospf network
:foreach i in [/routing ospf network find network=10.229.42.64/27] do={/routing ospf network remove $i;}
add network=10.229.42.64/27 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BNCLAlfonsoXIIIProp4] do={/routing bgp peer remove $i;}
add name="BNCLAlfonsoXIIIProp4" instance=default remote-address=10.229.42.70 remote-as=94545 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=SocisCable] do={/routing ospf interface remove $i;}
add interface=SocisCable
/ routing ospf network
:foreach i in [/routing ospf network find network=10.229.42.64/27] do={/routing ospf network remove $i;}
add network=10.229.42.64/27 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BNCLAlfonsoXIIIProp5] do={/routing bgp peer remove $i;}
add name="BNCLAlfonsoXIIIProp5" instance=default remote-address=10.229.42.71 remote-as=118384 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="10.229.42.65/27"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.229.42.65/27 network=10.229.42.64 broadcast=10.229.42.95 interface=SocisCable disabled=no comment="BNCLAlfonsoXIIISabi,BNCLAlfonsoXIIIProp1,BNCLAlfonsoXIIIProp2,BNCLAlfonsoXIIIProp3,BNCLAlfonsoXIIIProp4,BNCLAlfonsoXIIIProp5"
:foreach i in [/ip address find address="172.16.18.169/29"] do={/ip address remove $i;}
:delay 1
/ ip address add address=172.16.18.169/29 network=172.16.18.168 broadcast=172.16.18.175 interface=wdsBNCLAlfonsoXIII-Hipica disabled=no comment="BNCLAlfonsoXIIISabi,BNCLAlfonsoXIIIProp1,BNCLAlfonsoXIIIProp2,BNCLAlfonsoXIIIProp3,BNCLAlfonsoXIIIProp4,BNCLAlfonsoXIIIProp5"
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.90.65.225 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.90.65.225" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.90.65.225"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=44934 router-id=10.90.65.225 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf instance set default name=default router-id=10.90.65.225 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 44934-BNCLAlfonsoXIIIRB2011 executed."
/