# Generat per a:
# RouterOSv5.x
:log info "Unsolclic for 48818-CdPRTamesisMAIN going to be executed."
#
# Configuration for RouterOSv5.x
# Device: 48818-CdPRTamesisMAIN
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
#     a.Winbox (with Linux, wine required)
#     b.Terminal (telnet, ssh...)
#    Then execute the script with:
#      > /system script run script_name
# 2.-Fitxer importat:
#     Desa aquesta "sortida" a un fitxer, després puja'l al router
#     fent servir FTP amb un nom de l'estil "script_name.rsc".
#     (note, l'extensió ".rsc" es un requisit)
#     Executa el fitxer importat amb la comanda:
#      > /import script_name
# 3.-Telnet copia i enganxar:
#     Open a terminal session, and cut&paste this output
#     directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
#   according in how did you connect the cable to the miniPCI. Keep the
#   power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
#   (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
#   to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
#   the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=CdPRTamesisMAIN
#
# DNS (client & server cache) zone: 11275
/ip dns set servers=10.228.130.162,10.228.130.162 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 11275
/system ntp client set enabled=yes mode=unicast primary-ntp=10.228.130.162 secondary-ntp=10.228.130.162
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="CdPRTamesis" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
# Construct main bridge on wlan1 & ether1
/ interface bridge
add name="wLan/Lan"
/ interface bridge port
add interface=ether1 bridge=wLan/Lan
add interface=wlan1 bridge=wLan/Lan
:delay 1
#
# Radio#: 0 CdPRioTamesis8-AP0-o
/interface wireless set wlan1 name="wlan1" \
radio-name="CdPRioTamesis8-AP0-o" mode=ap-bridge ssid="guifi.net-CdPRioTamesis8-AP0-o" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=6 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan/Lan
/ip address
:foreach i in [find address="10.90.81.193/27"] do={remove $i}
/ ip address add address=10.90.81.193/27 network=10.90.81.192 broadcast=10.90.81.223 interface=wLan/Lan disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.90.81.192/27] do={/routing bgp network remove $i;}
add network=10.90.81.192/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wLan/Lan] do={/routing ospf interface remove $i;}
add interface=wLan/Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.90.81.192/27] do={/routing ospf network remove $i;}
add network=10.90.81.192/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wLan/Lan] do={/ip pool remove $i;}
/ip pool add name=dhcp-wLan/Lan ranges=10.90.81.199-10.90.81.222
:foreach i in [/ip dhcp-server find name=dhcp-wLan/Lan] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wLan/Lan interface=wLan/Lan address-pool=dhcp-wLan/Lan disabled=no
:foreach i in [/ip dhcp-server network find address="10.90.81.192/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.90.81.192/27 gateway=10.90.81.193 domain=guifi.net comment=dhcp-wLan/Lan
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.90.81.194 mac-address=00:00:00:00:00:00 client-id=CSGdfrd2Rd2 server=dhcp-wLan/Lan
add address=10.90.81.195 mac-address=00:27:22:C5:79:0D client-id=CsRioNervionRd1 server=dhcp-wLan/Lan
add address=10.90.81.196 mac-address=00:27:22:10:DC:7A client-id=CdPSerradal13DRd1 server=dhcp-wLan/Lan
add address=10.90.81.197 mac-address=DC:9F:DB:48:EC:D2 client-id=CASpenasalada16Rd1 server=dhcp-wLan/Lan
add address=10.90.81.198 mac-address=DC:9F:DB:96:24:3E client-id=graocubedo3Rd1 server=dhcp-wLan/Lan
add address=10.90.81.199 mac-address=24:A4:3C:00:CE:0E client-id=CSDonacion462Rd1 server=dhcp-wLan/Lan
add address=10.90.81.200 mac-address=DC:9F:DB:72:05:58 client-id=CSJosemariaguinotgalRd1 server=dhcp-wLan/Lan
add address=10.90.81.201 mac-address=F8:1A:67:5B:7F:72 client-id=CSRioTamesis1 server=dhcp-wLan/Lan
add address=10.90.81.202 mac-address=DC:9F:DB:46:62:FC client-id=CSViejodelMar17Rd1 server=dhcp-wLan/Lan
add address=10.90.81.203 mac-address=00:15:6D:9C:D1:BD client-id=CASrioter12Rd1 server=dhcp-wLan/Lan
add address=10.90.81.204 mac-address=00:27:22:44:AE:AF client-id=CdPIESelCaminasRd2 server=dhcp-wLan/Lan
add address=10.90.81.205 mac-address=24:A4:3C:78:56:C6 client-id=CdPRioNilo34Rd2 server=dhcp-wLan/Lan
add address=10.90.81.206 mac-address=DC:9F:DB:4A:53:8B client-id=CSTms2Rd1 server=dhcp-wLan/Lan
add address=10.90.81.208 mac-address=24:A4:3C:8C:46:84 client-id=cssamaalla32aRd1 server=dhcp-wLan/Lan
add address=10.90.81.209 mac-address=11:22:33:44:55:66 client-id=CSavalmssra33Rd1 server=dhcp-wLan/Lan
add address=10.90.81.210 mac-address=4C:5E:0C:EE:55:81 client-id=CdPManuelCubedo210Rd1 server=dhcp-wLan/Lan
add address=10.90.81.211 mac-address=78:8A:20:A0:3C:41 client-id=CSDncPtRgt2Rd1 server=dhcp-wLan/Lan
#
:delay 1
# Type: wds/p2p
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
#
# Radio#: 1 CdPRTmssT1-226
/interface wireless set wlan2 name="wlan2" \
radio-name="CdPRTmssT1-226" mode=ap-bridge ssid="guifi.net-CdPRTmssT1-226" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=22 \
frequency=5180 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wds/p2p
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan2] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_Almassora2MaigConstRd3" master-interface=wlan2 wds-address=00:15:6D:C0:A4:FA disabled=no
/ ip address add address=172.16.4.117/30 network=172.16.4.116 broadcast=172.16.4.119 interface=wds_Almassora2MaigConstRd3 disabled=no comment="wds_Almassora2MaigConstRd3"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_Almassora2MaigConstRd3] do={/routing ospf interface remove $i;}
add interface=wds_Almassora2MaigConstRd3
/ routing ospf network
:foreach i in [/routing ospf network find network=172.16.4.116/30] do={/routing ospf network remove $i;}
add network=172.16.4.116/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=Almassora2MaigConstRd3] do={/routing bgp peer remove $i;}
add name="Almassora2MaigConstRd3" instance=default remote-address=172.16.4.118 remote-as=14360 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
#
# Radio#: 2 CdPRTmssT2-010
/interface wireless set wlan3 name="wlan3" \
radio-name="CdPRTmssT2-010" mode=ap-bridge ssid="guifi.net-CdPRTmssT2-010" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=13 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wds/p2p
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan3] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_CdPRioDanubio8Main" master-interface=wlan3 wds-address=00:0C:42:CD:F0:AD disabled=no
/ ip address add address=172.16.5.77/30 network=172.16.5.76 broadcast=172.16.5.79 interface=wds_CdPRioDanubio8Main disabled=no comment="wds_CdPRioDanubio8Main"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_CdPRioDanubio8Main] do={/routing ospf interface remove $i;}
add interface=wds_CdPRioDanubio8Main
/ routing ospf network
:foreach i in [/routing ospf network find network=172.16.5.76/30] do={/routing ospf network remove $i;}
add network=172.16.5.76/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=CdPRioDanubio8Main] do={/routing bgp peer remove $i;}
add name="CdPRioDanubio8Main" instance=default remote-address=172.16.5.78 remote-as=33919 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
#
# Radio#: 3 CSCdPRTmssT3-68
/interface wireless set wlan4 name="wlan4" \
radio-name="CSCdPRTmssT3-68" mode=ap-bridge ssid="guifi.net-CSCdPRTmssT3-68" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wds/p2p
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan4] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_GrauCSSerradalMPRd2" master-interface=wlan4 wds-address=00:15:6D:00:00:00 disabled=no
/ ip address add address=172.16.8.245/30 network=172.16.8.244 broadcast=172.16.8.247 interface=wds_GrauCSSerradalMPRd2 disabled=no comment="wds_GrauCSSerradalMPRd2"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_GrauCSSerradalMPRd2] do={/routing ospf interface remove $i;}
add interface=wds_GrauCSSerradalMPRd2
/ routing ospf network
:foreach i in [/routing ospf network find network=172.16.8.244/30] do={/routing ospf network remove $i;}
add network=172.16.8.244/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=GrauCSSerradalMPRd2] do={/routing bgp peer remove $i;}
add name="GrauCSSerradalMPRd2" instance=default remote-address=172.16.8.246 remote-as=46731 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan/Lan] do={/routing ospf interface remove $i;}
add interface=Lan/Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.90.81.152/29] do={/routing ospf network remove $i;}
add network=10.90.81.152/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=CdPRTamesisRd3T1] do={/routing bgp peer remove $i;}
add name="CdPRTamesisRd3T1" instance=default remote-address=10.90.81.155 remote-as=48823 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan/Lan] do={/routing ospf interface remove $i;}
add interface=Lan/Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.90.81.152/29] do={/routing ospf network remove $i;}
add network=10.90.81.152/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=CdPRTamesisRd4T2] do={/routing bgp peer remove $i;}
add name="CdPRTamesisRd4T2" instance=default remote-address=10.90.81.156 remote-as=48825 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan/Lan] do={/routing ospf interface remove $i;}
add interface=Lan/Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.90.81.152/29] do={/routing ospf network remove $i;}
add network=10.90.81.152/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=CdPRTamesisRd5T3] do={/routing bgp peer remove $i;}
add name="CdPRTamesisRd5T3" instance=default remote-address=10.90.81.154 remote-as=52473 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="10.90.81.153/29"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.90.81.153/29 network=10.90.81.152 broadcast=10.90.81.159 interface=Lan/Lan disabled=no comment="CdPRTamesisRd3T1,CdPRTamesisRd4T2,CdPRTamesisRd5T3"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether1] do={/routing ospf interface remove $i;}
add interface=ether1
/ routing ospf network
:foreach i in [/routing ospf network find network=172.16.5.88/30] do={/routing ospf network remove $i;}
add network=172.16.5.88/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=CdPRTamesisViviendas] do={/routing bgp peer remove $i;}
add name="CdPRTamesisViviendas" instance=default remote-address=172.16.5.89 remote-as=48821 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
:foreach i in [/ip address find address="172.16.5.90/30"] do={/ip address remove $i;}
:delay 1
/ ip address add address=172.16.5.90/30 network=172.16.5.88 broadcast=172.16.5.91 interface=ether1 disabled=no comment="CdPRTamesisViviendas"
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.90.81.193 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.90.81.193" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.90.81.193"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=48818 router-id=10.90.81.193 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf instance set default name=default router-id=10.90.81.193 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 48818-CdPRTamesisMAIN executed."
/