# Generat per a:
# RouterOSv5.x
:log info "Unsolclic for 61275-GurbTecMundo07 going to be executed."
#
# Configuration for RouterOSv5.x
# Trasto: 61275-GurbTecMundo07
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
#     a.Winbox (with Linux, wine required)
#     b.Terminal (telnet, ssh...)
#    Then execute the script with:
#      > /system script run script_name
# 2.-Fitxer importat:
#     Desa aquesta "sortida" a un fitxer, després puja'l al router
#     fent servir FTP amb un nom de l'estil "script_name.rsc".
#     (note, l'extensió ".rsc" es un requisit)
#     Executa el fitxer importat amb la comanda:
#      > /import script_name
# 3.-Telnet copia i enganxar:
#     Open a terminal session, and cut&paste this output
#     directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
#   according in how did you connect the cable to the miniPCI. Keep the
#   power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
#   (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
#   to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
#   the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=GurbTecMundo07
#
# DNS (client & server cache) zone: 2451
/ip dns set servers=10.138.0.2,10.138.0.2 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 2451
/system ntp client set enabled=yes mode=unicast primary-ntp=10.138.0.2 secondary-ntp=10.138.0.2
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="GurbTecMundo" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
# Construct main bridge on wlan1 & ether1
/ interface bridge
add name="wLan/Lan"
/ interface bridge port
add interface=ether1 bridge=wLan/Lan
add interface=wlan1 bridge=wLan/Lan
:delay 1
#
# Radio#: 0 GurbTecMundo07
/interface wireless set wlan1 name="wlan1" \
radio-name="GurbTecMundo07" mode=ap-bridge ssid="guifi.net-GurbTecMundo07" \
band="2ghz-b" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsGurbTecMundo07
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_ROUGURB03" master-interface=wlan1 wds-address=00:0C:42:FE:3F:06 disabled=no
/ ip address add address=172.25.0.173/30 network=172.25.0.172 broadcast=172.25.0.175 interface=wds_ROUGURB03 disabled=no comment="wds_ROUGURB03"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_ROUGURB03] do={/routing ospf interface remove $i;}
add interface=wds_ROUGURB03
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.0.172/30] do={/routing ospf network remove $i;}
add network=172.25.0.172/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=ROUGURB03] do={/routing bgp peer remove $i;}
add name="ROUGURB03" instance=default remote-address=172.25.0.174 remote-as=32394 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
# Type: other
/ip address
:foreach i in [find address="172.25.0.229/30"] do={remove $i}
/ ip address add address=172.25.0.229/30 network=172.25.0.228 broadcast=172.25.0.231 interface=wlan1 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=172.25.0.228/30] do={/routing bgp network remove $i;}
add network=172.25.0.228/30 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan1] do={/routing ospf interface remove $i;}
add interface=wlan1
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.0.228/30] do={/routing ospf network remove $i;}
add network=172.25.0.228/30 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan1] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan1 ranges=172.25.0.230-172.25.0.230
:foreach i in [/ip dhcp-server find name=dhcp-wlan1] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan1 interface=wlan1 address-pool=dhcp-wlan1 disabled=yes
:foreach i in [/ip dhcp-server network find address="172.25.0.228/30"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=172.25.0.228/30 gateway=172.25.0.229 domain=guifi.net comment=dhcp-wlan1
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=172.25.0.230 mac-address=00:00:00:00:00:00 client-id=GurbTecMundoST server=dhcp-wlan1
#
:delay 1
# Type: wLan/Lan
/ip address
:foreach i in [find address="10.138.14.161/29"] do={remove $i}
/ ip address add address=10.138.14.161/29 network=10.138.14.160 broadcast=10.138.14.167 interface=wLan/Lan disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.138.14.160/29] do={/routing bgp network remove $i;}
add network=10.138.14.160/29 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wLan/Lan] do={/routing ospf interface remove $i;}
add interface=wLan/Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.138.14.160/29] do={/routing ospf network remove $i;}
add network=10.138.14.160/29 area=backbone disabled=no
/ip address
:foreach i in [find address="172.25.2.2/30"] do={remove $i}
/ ip address add address=172.25.2.2/30 network=172.25.2.0 broadcast=172.25.2.3 interface=wLan/Lan disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=172.25.2.0/30] do={/routing bgp network remove $i;}
add network=172.25.2.0/30 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wLan/Lan] do={/routing ospf interface remove $i;}
add interface=wLan/Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.2.0/30] do={/routing ospf network remove $i;}
add network=172.25.2.0/30 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wLan/Lan] do={/ip pool remove $i;}
/ip pool add name=dhcp-wLan/Lan ranges=172.25.2.2-172.25.2.2
:foreach i in [/ip dhcp-server find name=dhcp-wLan/Lan] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wLan/Lan interface=wLan/Lan address-pool=dhcp-wLan/Lan disabled=yes
:foreach i in [/ip dhcp-server network find address="172.25.2.0/30"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=172.25.2.0/30 gateway=172.25.2.1 domain=guifi.net comment=dhcp-wLan/Lan
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=172.25.2.1 mac-address=00:00:00:00:00:00 client-id=GurbTecMUNDO01 server=dhcp-wLan/Lan
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
:foreach i in [/ip address find address="10.148.224.1/19"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.148.224.1/19 network=10.148.224.0 broadcast=10.148.255.255 interface=ether1 disabled=no comment=""
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=172.25.2.2 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="172.25.2.2" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="172.25.2.2"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=61275 router-id=172.25.2.2 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf instance set default name=default router-id=172.25.2.2 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 61275-GurbTecMundo07 executed."
/