# Generat per a:
# RouterOSv3.x
:log info "Unsolclic for 24402-MatGeganta_RB-433 going to be executed."
#
# Configuration for RouterOSv3.x
# Trasto: 24402-MatGeganta_RB-433
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
#     a.Winbox (with Linux, wine required)
#     b.Terminal (telnet, ssh...)
#    Then execute the script with:
#      > /system script run script_name
# 2.-Fitxer importat:
#     Desa aquesta "sortida" a un fitxer, després puja'l al router
#     fent servir FTP amb un nom de l'estil "script_name.rsc".
#     (note, l'extensió ".rsc" es un requisit)
#     Executa el fitxer importat amb la comanda:
#      > /import script_name
# 3.-Telnet copia i enganxar:
#     Open a terminal session, and cut&paste this output
#     directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
#   according in how did you connect the cable to the miniPCI. Keep the
#   power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
#   (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
#   to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
#   the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=MatGeganta_RB-433
#
# DNS (client & server cache) zone: 11031
/ip dns set primary-dns=10.139.56.2 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 11031
/system ntp client set enabled=yes mode=unicast primary-ntp=10.139.56.2
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp set contact="guifi@guifi.net" enabled=yes location="MatMariaRosa"
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
# Construct main bridge on wlan1 & ether1
/ interface bridge
add name="wLan/Lan"
/ interface bridge port
add interface=ether1 bridge=wLan/Lan
add interface=wlan1 bridge=wLan/Lan
:delay 1
#
# Radio#: 0 MatGeganta
/interface wireless set wlan1 name="wlan1" \
radio-name="MatGeganta" mode=ap-bridge ssid="guifi.net-MatGeganta" \
band="2.4ghz-b" \
frequency-mode=regulatory-domain country=spain antenna-gain=10 \
frequency=2412 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsMatGeganta
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
# Type: wLan/Lan
/ip address
:foreach i in [find address="10.139.66.193/26"] do={remove $i}
/ ip address add address=10.139.66.193/26 network=10.139.66.192 broadcast=10.139.66.255 interface=wLan/Lan disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.139.66.192/26] do={/routing bgp network remove $i;}
add network=10.139.66.192/26 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wLan/Lan] do={/routing ospf interface remove $i;}
add interface=wLan/Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.139.66.192/26] do={/routing ospf network remove $i;}
add network=10.139.66.192/26 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wLan/Lan] do={/ip pool remove $i;}
/ip pool add name=dhcp-wLan/Lan ranges=10.139.66.199-10.139.66.254
:foreach i in [/ip dhcp-server find name=dhcp-wLan/Lan] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wLan/Lan interface=wLan/Lan address-pool=dhcp-wLan/Lan disabled=no
:foreach i in [/ip dhcp-server network find address="10.139.66.192/26"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.139.66.192/26 gateway=10.139.66.193 domain=guifi.net comment=dhcp-wLan/Lan
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.139.66.204 mac-address=00:00:00:00:00:00 client-id=MatGeganta7m server=dhcp-wLan/Lan
add address=10.139.66.207 mac-address=00:00:00:00:00:00 client-id=MATsalvadorespriu137Rd2 server=dhcp-wLan/Lan
add address=10.139.66.210 mac-address=00:C0:CA:1D:A2:E8 client-id=MatTornerAvilaRd1 server=dhcp-wLan/Lan
add address=10.139.66.217 mac-address=00:15:6D:F8:78:72 client-id=MatFredericMistral22Rd2 server=dhcp-wLan/Lan
add address=10.139.66.229 mac-address=00:00:00:00:00:33 client-id=MatAvVelodrom91Rd1 server=dhcp-wLan/Lan
#
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.140.52.33/27"] do={remove $i}
/ ip address add address=10.140.52.33/27 network=10.140.52.32 broadcast=10.140.52.63 interface=wlan1 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.140.52.32/27] do={/routing bgp network remove $i;}
add network=10.140.52.32/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan1] do={/routing ospf interface remove $i;}
add interface=wlan1
/ routing ospf network
:foreach i in [/routing ospf network find network=10.140.52.32/27] do={/routing ospf network remove $i;}
add network=10.140.52.32/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan1] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan1 ranges=10.140.52.39-10.140.52.62
:foreach i in [/ip dhcp-server find name=dhcp-wlan1] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan1 interface=wlan1 address-pool=dhcp-wlan1 disabled=no
:foreach i in [/ip dhcp-server network find address="10.140.52.32/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.140.52.32/27 gateway=10.140.52.33 domain=guifi.net comment=dhcp-wlan1
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
#
:delay 1
#
# Radio#: 1 MatGeganta-Isern
/interface wireless set wlan2 name="wlan2" \
radio-name="MatGeganta-Isern" mode=ap-bridge ssid="guifi.net-MatGeganta-Isern" \
band="5ghz" \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=5320 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsMatGeganta-Isern
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan2] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_MatIsernRB600" master-interface=wlan2 wds-address=00:C0:CA:1D:9F:34 disabled=no
/ ip address add address=172.25.38.37/30 network=172.25.38.36 broadcast=172.25.38.39 interface=wds_MatIsernRB600 disabled=no comment="wds_MatIsernRB600"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_MatIsernRB600] do={/routing ospf interface remove $i;}
add interface=wds_MatIsernRB600
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.38.36/30] do={/routing ospf network remove $i;}
add network=172.25.38.36/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=MatIsernRB600] do={/routing bgp peer remove $i;}
add name="MatIsernRB600" instance=default remote-address=172.25.38.38 remote-as=13728 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
#
# Radio#: 2 MatGeganta-AP3-5
/interface wireless set wlan3 name="wlan3" \
radio-name="MatGeganta-AP3-5" mode=ap-bridge ssid="guifi.net-MatGeganta-AP3-5" \
band="5ghz" \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=5180 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
#
# Radio#: 3 MatGeganta-Molins
/interface wireless set wlan4 name="wlan4" \
radio-name="MatGeganta-Molins" mode=ap-bridge ssid="guifi.net-MatGeganta-Molins" \
band="5ghz" \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsMatGeganta-Molins
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan4] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.91.194.65/27"] do={remove $i}
/ ip address add address=10.91.194.65/27 network=10.91.194.64 broadcast=10.91.194.95 interface=wlan4 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.91.194.64/27] do={/routing bgp network remove $i;}
add network=10.91.194.64/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan4] do={/routing ospf interface remove $i;}
add interface=wlan4
/ routing ospf network
:foreach i in [/routing ospf network find network=10.91.194.64/27] do={/routing ospf network remove $i;}
add network=10.91.194.64/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan4] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan4 ranges=10.91.194.71-10.91.194.94
:foreach i in [/ip dhcp-server find name=dhcp-wlan4] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan4 interface=wlan4 address-pool=dhcp-wlan4 disabled=no
:foreach i in [/ip dhcp-server network find address="10.91.194.64/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.91.194.64/27 gateway=10.91.194.65 domain=guifi.net comment=dhcp-wlan4
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.91.194.67 mac-address=00:00:00:00:00:00 client-id=MatFredericMistral8Rd1 server=dhcp-wlan4
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether1] do={/routing ospf interface remove $i;}
add interface=ether1
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.37.8/30] do={/routing ospf network remove $i;}
add network=172.25.37.8/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=MatGegantaOmnitic] do={/routing bgp peer remove $i;}
add name="MatGegantaOmnitic" instance=default remote-address=172.25.37.10 remote-as=44910 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
:foreach i in [/ip address find address="172.25.37.9/30"] do={/ip address remove $i;}
:delay 1
/ ip address add address=172.25.37.9/30 network=172.25.37.8 broadcast=172.25.37.11 interface=ether1 disabled=no comment="MatGegantaOmnitic"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether1] do={/routing ospf interface remove $i;}
add interface=ether1
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.49.140/30] do={/routing ospf network remove $i;}
add network=172.25.49.140/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=MatGegantaST] do={/routing bgp peer remove $i;}
add name="MatGegantaST" instance=default remote-address=172.25.49.142 remote-as=63314 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
:foreach i in [/ip address find address="172.25.49.141/30"] do={/ip address remove $i;}
:delay 1
/ ip address add address=172.25.49.141/30 network=172.25.49.140 broadcast=172.25.49.143 interface=ether1 disabled=no comment="MatGegantaST"
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.139.66.193 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.139.66.193" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.139.66.193"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=24402 router-id=10.139.66.193 \
redistribute-connected=yes redistribute-static=yes redistribute-rip=yes \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf set router-id=10.139.66.193 distribute-default=never redistribute-connected=no \
redistribute-static=no redistribute-rip=no redistribute-bgp=as-type-1
#
:log info "Unsolclic for 24402-MatGeganta_RB-433 executed."
/