# Generat per a:
# RouterOSv5.x
:log info "Unsolclic for 36611-PerafitaBiblioSTs going to be executed."
#
# Configuration for RouterOSv5.x
# Device: 36611-PerafitaBiblioSTs
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
# a.Winbox (with Linux, wine required)
# b.Terminal (telnet, ssh...)
# Then execute the script with:
# > /system script run script_name
# 2.-Fitxer importat:
# Desa aquesta "sortida" a un fitxer, després puja'l al router
# fent servir FTP amb un nom de l'estil "script_name.rsc".
# (note, l'extensió ".rsc" es un requisit)
# Executa el fitxer importat amb la comanda:
# > /import script_name
# 3.-Telnet copia i enganxar:
# Open a terminal session, and cut&paste this output
# directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
# according in how did you connect the cable to the miniPCI. Keep the
# power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
# (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
# to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
# the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=PerafitaBiblioSTs
#
# DNS (client & server cache) zone: 5639
/ip dns set servers=10.138.57.2 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 5639
/system ntp client set enabled=yes mode=unicast primary-ntp=10.138.57.2
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="PerafitaBiblio" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
:delay 1
#
# Radio#: 0 PerafitaST3
/interface wireless set wlan1 name="wlan1" \
radio-name="PerafitaST3" mode=ap-bridge ssid="guifi.net-PerafitaST3" \
band="2ghz-b" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsPerafitaST3
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
#
# Radio#: 1 PerafitaBiblio-SMADip
/interface wireless set wlan2 name="wlan2" \
radio-name="PerafitaBiblio-SMADip" mode=ap-bridge ssid="guifi.net-PerafitaBiblio-SMADip" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=5680 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsPerafitaBiblio-SMADip
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan2] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_SMADipST02" master-interface=wlan2 wds-address=99:99:99:99:99:99 disabled=no
/ ip address add address=172.25.50.153/29 network=172.25.50.152 broadcast=172.25.50.159 interface=wds_SMADipST02 disabled=no comment="wds_SMADipST02"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_SMADipST02] do={/routing ospf interface remove $i;}
add interface=wds_SMADipST02
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.50.152/29] do={/routing ospf network remove $i;}
add network=172.25.50.152/29 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=SMADipST02] do={/routing bgp peer remove $i;}
add name="SMADipST02" instance=default remote-address=172.25.50.156 remote-as=70311 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
#
# Radio#: 2 PerafitaBib-Sup
/interface wireless set wlan3 name="wlan3" \
radio-name="PerafitaBib-Sup" mode=ap-bridge ssid="guifi.net-PerafitaBib-Sup" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=5620 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsPerafitaBib-Sup
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan3] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_PerafitaSerdaST" master-interface=wlan3 wds-address=99:99:99:99:99:9B disabled=no
/ ip address add address=172.25.50.59/29 network=172.25.50.56 broadcast=172.25.50.63 interface=wds_PerafitaSerdaST disabled=no comment="wds_PerafitaSerdaST"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_PerafitaSerdaST] do={/routing ospf interface remove $i;}
add interface=wds_PerafitaSerdaST
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.50.56/29] do={/routing ospf network remove $i;}
add network=172.25.50.56/29 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=PerafitaSerdaST] do={/routing bgp peer remove $i;}
add name="PerafitaSerdaST" instance=default remote-address=172.25.50.58 remote-as=33593 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=vlan128_PerafitaBibAp51] do={/routing ospf interface remove $i;}
add interface=vlan128_PerafitaBibAp51
/ routing ospf network
:foreach i in [/routing ospf network find network=10.138.57.224/27] do={/routing ospf network remove $i;}
add network=10.138.57.224/27 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=PerafitaBiblioAP51] do={/routing bgp peer remove $i;}
add name="PerafitaBiblioAP51" instance=default remote-address=10.138.57.225 remote-as=44069 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
:foreach i in [/ip address find address="10.138.57.226/27"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.138.57.226/27 network=10.138.57.224 broadcast=10.138.57.255 interface=vlan128_PerafitaBibAp51 disabled=no comment="PerafitaBiblioAP51"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=vlan127_PerafitaCafeDelMig] do={/routing ospf interface remove $i;}
add interface=vlan127_PerafitaCafeDelMig
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.47.224/30] do={/routing ospf network remove $i;}
add network=172.25.47.224/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=PerafitaCafeDelMigRb750GL] do={/routing bgp peer remove $i;}
add name="PerafitaCafeDelMigRb750GL" instance=default remote-address=172.25.47.225 remote-as=36957 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
:foreach i in [/ip address find address="172.25.47.226/30"] do={/ip address remove $i;}
:delay 1
/ ip address add address=172.25.47.226/30 network=172.25.47.224 broadcast=172.25.47.227 interface=vlan127_PerafitaCafeDelMig disabled=no comment="PerafitaCafeDelMigRb750GL"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether2] do={/routing ospf interface remove $i;}
add interface=ether2
/ routing ospf network
:foreach i in [/routing ospf network find network=10.138.57.0/27] do={/routing ospf network remove $i;}
add network=10.138.57.0/27 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=PerafitaBiblioST1] do={/routing bgp peer remove $i;}
add name="PerafitaBiblioST1" instance=default remote-address=10.138.57.1 remote-as=3739 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
:foreach i in [/ip address find address="10.138.57.18/27"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.138.57.18/27 network=10.138.57.0 broadcast=10.138.57.31 interface=ether2 disabled=no comment="PerafitaBiblioST1"
:foreach i in [/ip address find address="10.139.250.21/32"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.139.250.21/32 network=10.139.250.21 broadcast=10.139.250.21 interface=Lan disabled=no comment="PerafitaBiblioST1"
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.139.250.21 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.139.250.21" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.139.250.21"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=36611 router-id=10.139.250.21 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf instance set default name=default router-id=10.139.250.21 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 36611-PerafitaBiblioSTs executed."
/