# Generat per a:
# RouterOSv5.x
:log info "Unsolclic for 52224-OlotVolcaSafont18wds going to be executed."
#
# Configuration for RouterOSv5.x
# Trasto: 52224-OlotVolcaSafont18wds
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
# a.Winbox (with Linux, wine required)
# b.Terminal (telnet, ssh...)
# Then execute the script with:
# > /system script run script_name
# 2.-Fitxer importat:
# Desa aquesta "sortida" a un fitxer, després puja'l al router
# fent servir FTP amb un nom de l'estil "script_name.rsc".
# (note, l'extensió ".rsc" es un requisit)
# Executa el fitxer importat amb la comanda:
# > /import script_name
# 3.-Telnet copia i enganxar:
# Open a terminal session, and cut&paste this output
# directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
# according in how did you connect the cable to the miniPCI. Keep the
# power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
# (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
# to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
# the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=OlotVolcaSafont18wds
#
# DNS (client & server cache) zone: 2440
/ip dns set servers=10.139.38.2,10.138.78.209 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 2440
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="OlotVolcaSafont18" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
:delay 1
#
# Radio#: 0 OlotltVlcSfnt18wdsAP0
/interface wireless set wlan1 name="wlan1" \
radio-name="OlotltVlcSfnt18wdsAP0" mode=ap-bridge ssid="guifi.net-OlotltVlcSfnt18wdsAP0" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=5 \
frequency=5200 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: Lan
/ip address
:foreach i in [find address="10.140.58.161/27"] do={remove $i}
/ ip address add address=10.140.58.161/27 network=10.140.58.160 broadcast=10.140.58.191 interface=wlan1 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.140.58.160/27] do={/routing bgp network remove $i;}
add network=10.140.58.160/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan1] do={/routing ospf interface remove $i;}
add interface=wlan1
/ routing ospf network
:foreach i in [/routing ospf network find network=10.140.58.160/27] do={/routing ospf network remove $i;}
add network=10.140.58.160/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan1] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan1 ranges=10.140.58.167-10.140.58.190
:foreach i in [/ip dhcp-server find name=dhcp-wlan1] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan1 interface=wlan1 address-pool=dhcp-wlan1 disabled=no
:foreach i in [/ip dhcp-server network find address="10.140.58.160/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.140.58.160/27 gateway=10.140.58.161 domain=guifi.net comment=dhcp-wlan1
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.140.58.162 mac-address=00:00:00:00:00:00 client-id=OlotVolcaSafont18Rd3 server=dhcp-wlan1
#
:delay 1
# Type: wdsOlotltVlcSfnt18wdsAP0
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_RiudaTaniaOmnitik" master-interface=wlan1 wds-address=FF:FF:FF:FF:FF:02 disabled=no
/ ip address add address=172.25.62.21/30 network=172.25.62.20 broadcast=172.25.62.23 interface=wds_RiudaTaniaOmnitik disabled=no comment="wds_RiudaTaniaOmnitik"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_RiudaTaniaOmnitik] do={/routing ospf interface remove $i;}
add interface=wds_RiudaTaniaOmnitik
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.62.20/30] do={/routing ospf network remove $i;}
add network=172.25.62.20/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=RiudaTaniaOmnitik] do={/routing bgp peer remove $i;}
add name="RiudaTaniaOmnitik" instance=default remote-address=172.25.62.22 remote-as=71176 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
# Type: wds/p2p
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_OlotSaiols" master-interface=wlan1 wds-address=00:0C:42:2B:50:43 disabled=no
/ ip address add address=172.25.35.57/30 network=172.25.35.56 broadcast=172.25.35.59 interface=wds_OlotSaiols disabled=no comment="wds_OlotSaiols"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_OlotSaiols] do={/routing ospf interface remove $i;}
add interface=wds_OlotSaiols
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.35.56/30] do={/routing ospf network remove $i;}
add network=172.25.35.56/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=OlotSaiols] do={/routing bgp peer remove $i;}
add name="OlotSaiols" instance=default remote-address=172.25.35.58 remote-as=13270 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
/ interface wireless wds
add name="wds_LpresvolracoRd1" master-interface=wlan1 wds-address=00:0C:42:39:49:DF disabled=no
/ ip address add address=172.25.37.5/30 network=172.25.37.4 broadcast=172.25.37.7 interface=wds_LpresvolracoRd1 disabled=no comment="wds_LpresvolracoRd1"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_LpresvolracoRd1] do={/routing ospf interface remove $i;}
add interface=wds_LpresvolracoRd1
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.37.4/30] do={/routing ospf network remove $i;}
add network=172.25.37.4/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=LpresvolracoRd1] do={/routing bgp peer remove $i;}
add name="LpresvolracoRd1" instance=default remote-address=172.25.37.6 remote-as=17125 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
/ interface wireless wds
add name="wds_OlotClara9OMNITIK" master-interface=wlan1 wds-address=00:00:00:00:00:00 disabled=no
/ ip address add address=172.25.40.169/30 network=172.25.40.168 broadcast=172.25.40.171 interface=wds_OlotClara9OMNITIK disabled=no comment="wds_OlotClara9OMNITIK"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_OlotClara9OMNITIK] do={/routing ospf interface remove $i;}
add interface=wds_OlotClara9OMNITIK
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.40.168/30] do={/routing ospf network remove $i;}
add network=172.25.40.168/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=OlotClara9OMNITIK] do={/routing bgp peer remove $i;}
add name="OlotClara9OMNITIK" instance=default remote-address=172.25.40.170 remote-as=78173 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
/ interface wireless wds
add name="wds_OlotCamimontsacop41Rd1" master-interface=wlan1 wds-address=00:0C:42:CE:4B:4F disabled=no
/ ip address add address=172.25.45.37/30 network=172.25.45.36 broadcast=172.25.45.39 interface=wds_OlotCamimontsacop41Rd1 disabled=no comment="wds_OlotCamimontsacop41Rd1"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_OlotCamimontsacop41Rd1] do={/routing ospf interface remove $i;}
add interface=wds_OlotCamimontsacop41Rd1
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.45.36/30] do={/routing ospf network remove $i;}
add network=172.25.45.36/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=OlotCamimontsacop41Rd1] do={/routing bgp peer remove $i;}
add name="OlotCamimontsacop41Rd1" instance=default remote-address=172.25.45.38 remote-as=53970 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
/ interface wireless wds
add name="wds_OlotXdpNBAulina" master-interface=wlan1 wds-address=00:15:6D:2E:3D:C4 disabled=no
/ ip address add address=172.25.46.208/29 network=172.25.46.208 broadcast=172.25.46.215 interface=wds_OlotXdpNBAulina disabled=no comment="wds_OlotXdpNBAulina"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_OlotXdpNBAulina] do={/routing ospf interface remove $i;}
add interface=wds_OlotXdpNBAulina
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.46.208/29] do={/routing ospf network remove $i;}
add network=172.25.46.208/29 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=OlotXdpNBAulina] do={/routing bgp peer remove $i;}
add name="OlotXdpNBAulina" instance=default remote-address=172.25.46.209 remote-as=24153 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
/ interface wireless wds
add name="wds_Olotvistalegra52Omintik" master-interface=wlan1 wds-address=4C:5E:0C:2E:96:3F disabled=no
/ ip address add address=172.25.58.142/30 network=172.25.58.140 broadcast=172.25.58.143 interface=wds_Olotvistalegra52Omintik disabled=no comment="wds_Olotvistalegra52Omintik"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_Olotvistalegra52Omintik] do={/routing ospf interface remove $i;}
add interface=wds_Olotvistalegra52Omintik
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.58.140/30] do={/routing ospf network remove $i;}
add network=172.25.58.140/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=Olotvistalegra52Omintik] do={/routing bgp peer remove $i;}
add name="Olotvistalegra52Omintik" instance=default remote-address=172.25.58.141 remote-as=66095 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
/ interface wireless wds
add name="wds_OlotBruixes7Rd2" master-interface=wlan1 wds-address=FF:FF:FF:FF:FF:01 disabled=no
/ ip address add address=172.25.68.138/30 network=172.25.68.136 broadcast=172.25.68.139 interface=wds_OlotBruixes7Rd2 disabled=no comment="wds_OlotBruixes7Rd2"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_OlotBruixes7Rd2] do={/routing ospf interface remove $i;}
add interface=wds_OlotBruixes7Rd2
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.68.136/30] do={/routing ospf network remove $i;}
add network=172.25.68.136/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=OlotBruixes7Rd2] do={/routing bgp peer remove $i;}
add name="OlotBruixes7Rd2" instance=default remote-address=172.25.68.137 remote-as=60725 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.140.58.161 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.140.58.161" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.140.58.161"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=52224 router-id=10.140.58.161 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf instance set default name=default router-id=10.140.58.161 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 52224-OlotVolcaSafont18wds executed."
/