# Generat per a:
# RouterOSv5.x
:log info "Unsolclic for 55428-BiRBibliotecaST going to be executed."
#
# Configuration for RouterOSv5.x
# Device: 55428-BiRBibliotecaST
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
#     a.Winbox (with Linux, wine required)
#     b.Terminal (telnet, ssh...)
#    Then execute the script with:
#      > /system script run script_name
# 2.-Fitxer importat:
#     Desa aquesta "sortida" a un fitxer, després puja'l al router
#     fent servir FTP amb un nom de l'estil "script_name.rsc".
#     (note, l'extensió ".rsc" es un requisit)
#     Executa el fitxer importat amb la comanda:
#      > /import script_name
# 3.-Telnet copia i enganxar:
#     Open a terminal session, and cut&paste this output
#     directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
#   according in how did you connect the cable to the miniPCI. Keep the
#   power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
#   (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
#   to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
#   the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=BiRBibliotecaST
#
# DNS (client & server cache) zone: 9363
/ip dns set servers=10.138.27.194,10.139.6.130 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 9363
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="BiRBiblioteca" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
:delay 1
#
# Radio#: 0 BiRBiblioBiRMirador
/interface wireless set wlan1 name="wlan1" \
radio-name="BiRBiblioBiRMirador" mode=ap-bridge ssid="guifi.net-BiRBiblioBiRMirador" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
#
# Radio#: 1 wdsFOBiblioteca-CPD
/interface wireless set wlan2 name="wlan2" \
radio-name="wdsFOBiblioteca-CPD" mode=ap-bridge ssid="guifi.net-wdsFOBiblioteca-CPD" \
band="2ghz-b" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdswdsFOBiblioteca-CPD
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan2] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_BiRGoufoneCPDRou03" master-interface=wlan2 wds-address=00:00:00:00:00:00 disabled=no
/ ip address add address=172.25.254.93/30 network=172.25.254.92 broadcast=172.25.254.95 interface=wds_BiRGoufoneCPDRou03 disabled=no comment="wds_BiRGoufoneCPDRou03"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_BiRGoufoneCPDRou03] do={/routing ospf interface remove $i;}
add interface=wds_BiRGoufoneCPDRou03
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.254.92/30] do={/routing ospf network remove $i;}
add network=172.25.254.92/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=BiRGoufoneCPDRou03] do={/routing bgp peer remove $i;}
add name="BiRGoufoneCPDRou03" instance=default remote-address=172.25.254.94 remote-as=99140 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.90.152.160/27] do={/routing ospf network remove $i;}
add network=10.90.152.160/27 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=BiRBibliotecaBiRMiradorNB] do={/routing bgp peer remove $i;}
add name="BiRBibliotecaBiRMiradorNB" instance=default remote-address=10.90.152.162 remote-as=55430 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.90.152.160/27] do={/routing ospf network remove $i;}
add network=10.90.152.160/27 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=BiRBibliotecaAlarma] do={/routing bgp peer remove $i;}
add name="BiRBibliotecaAlarma" instance=default remote-address=10.90.152.164 remote-as=60743 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.90.152.160/27] do={/routing ospf network remove $i;}
add network=10.90.152.160/27 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=BiRBibliotecaBiRCastMontbui] do={/routing bgp peer remove $i;}
add name="BiRBibliotecaBiRCastMontbui" instance=default remote-address=10.90.152.165 remote-as=72953 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
:foreach i in [/ip address find address="10.90.152.161/27"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.90.152.161/27 network=10.90.152.160 broadcast=10.90.152.191 interface=Lan disabled=no comment="BiRBibliotecaBiRMiradorNB,BiRBibliotecaAlarma,BiRBibliotecaBiRCastMontbui"
:foreach i in [/ip address find address="172.25.37.164/30"] do={/ip address remove $i;}
:delay 1
/ ip address add address=172.25.37.164/30 network=172.25.37.164 broadcast=172.25.37.167 interface=Lan disabled=no comment="BiRBibliotecaBiRMiradorNB,BiRBibliotecaAlarma,BiRBibliotecaBiRCastMontbui"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether1] do={/routing ospf interface remove $i;}
add interface=ether1
/ routing ospf network
:foreach i in [/routing ospf network find network=10.90.152.224/27] do={/routing ospf network remove $i;}
add network=10.90.152.224/27 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BiRBibliotecaAP5O2] do={/routing bgp peer remove $i;}
add name="BiRBibliotecaAP5O2" instance=default remote-address=10.90.152.225 remote-as=56876 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="10.90.152.226/27"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.90.152.226/27 network=10.90.152.224 broadcast=10.90.152.255 interface=ether1 disabled=no comment="BiRBibliotecaAP5O2"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=ether2] do={/routing ospf interface remove $i;}
add interface=ether2
/ routing ospf network
:foreach i in [/routing ospf network find network=10.90.153.0/27] do={/routing ospf network remove $i;}
add network=10.90.153.0/27 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=BiRBibliotecaOmniAP5G] do={/routing bgp peer remove $i;}
add name="BiRBibliotecaOmniAP5G" instance=default remote-address=10.90.153.1 remote-as=56877 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
:foreach i in [/ip address find address="10.90.153.2/27"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.90.153.2/27 network=10.90.153.0 broadcast=10.90.153.31 interface=ether2 disabled=no comment="BiRBibliotecaOmniAP5G"
:foreach i in [/ip address find address="10.90.152.193/27"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.90.152.193/27 network=10.90.152.192 broadcast=10.90.152.223 interface=ether4 disabled=no comment="BiRBibliotecaOmniAP5G"
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.90.152.161 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.90.152.161" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.90.152.161"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=55428 router-id=10.90.152.161 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf instance set default name=default router-id=10.90.152.161 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 55428-BiRBibliotecaST executed."
/