# Generat per a:
# RouterOSv5.x
:log info "Unsolclic for 5613-SBGTorreAPs going to be executed."
#
# Configuration for RouterOSv5.x
# Device: 5613-SBGTorreAPs
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
#     a.Winbox (with Linux, wine required)
#     b.Terminal (telnet, ssh...)
#    Then execute the script with:
#      > /system script run script_name
# 2.-Fitxer importat:
#     Desa aquesta "sortida" a un fitxer, després puja'l al router
#     fent servir FTP amb un nom de l'estil "script_name.rsc".
#     (note, l'extensió ".rsc" es un requisit)
#     Executa el fitxer importat amb la comanda:
#      > /import script_name
# 3.-Telnet copia i enganxar:
#     Open a terminal session, and cut&paste this output
#     directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
#   according in how did you connect the cable to the miniPCI. Keep the
#   power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
#   (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
#   to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
#   the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=SBGTorreAPs
#
# DNS (client & server cache) zone: 2462
/ip dns set servers=10.138.42.3,10.138.120.66 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 2462
/system ntp client set enabled=yes mode=unicast primary-ntp=10.138.0.2 secondary-ntp=10.138.57.2
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="SBGTorre" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
# Construct main bridge on wlan1 & ether1
/ interface bridge
add name="wLan/Lan"
/ interface bridge port
add interface=ether1 bridge=wLan/Lan
add interface=wlan1 bridge=wLan/Lan
:delay 1
#
# Radio#: 0 SBGTorreAPNord
/interface wireless set wlan1 name="wlan1" \
radio-name="SBGTorreAPNord" mode=ap-bridge ssid="guifi.net-SBGTorreAPNord" \
band="2ghz-b" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=2452 \
dfs-mode=none \
antenna-mode=ant-b wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsSBGTorreAPNord
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
# Type: wLan/Lan
/ip address
:foreach i in [find address="10.138.148.65/27"] do={remove $i}
/ ip address add address=10.138.148.65/27 network=10.138.148.64 broadcast=10.138.148.95 interface=wLan/Lan disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.138.148.64/27] do={/routing bgp network remove $i;}
add network=10.138.148.64/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wLan/Lan] do={/routing ospf interface remove $i;}
add interface=wLan/Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.138.148.64/27] do={/routing ospf network remove $i;}
add network=10.138.148.64/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wLan/Lan] do={/ip pool remove $i;}
/ip pool add name=dhcp-wLan/Lan ranges=10.138.148.71-10.138.148.94
:foreach i in [/ip dhcp-server find name=dhcp-wLan/Lan] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wLan/Lan interface=wLan/Lan address-pool=dhcp-wLan/Lan disabled=no
:foreach i in [/ip dhcp-server network find address="10.138.148.64/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.138.148.64/27 gateway=10.138.148.65 domain=guifi.net comment=dhcp-wLan/Lan
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.138.148.66 mac-address=00:0F:77:31:32:B0 client-id=SBGpauRd1 server=dhcp-wLan/Lan
add address=10.138.148.67 mac-address=00:15:6D:A9:BD:48 client-id=SBGERJRd2 server=dhcp-wLan/Lan
add address=10.138.148.68 mac-address=00:27:22:05:B7:9C client-id=SBGalbertBRd1 server=dhcp-wLan/Lan
add address=10.138.148.69 mac-address=00:15:6D:D9:08:A0 client-id=SBGOscarRodriguezRd1 server=dhcp-wLan/Lan
add address=10.138.148.70 mac-address=00:15:6D:1B:01:1A client-id=SBGBisbeRd2 server=dhcp-wLan/Lan
add address=10.138.148.72 mac-address=00:15:6D:DC:B0:C3 client-id=SBGSalaExposicioRd1 server=dhcp-wLan/Lan
#
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.138.42.161/27"] do={remove $i}
/ ip address add address=10.138.42.161/27 network=10.138.42.160 broadcast=10.138.42.191 interface=wlan1 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.138.42.160/27] do={/routing bgp network remove $i;}
add network=10.138.42.160/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan1] do={/routing ospf interface remove $i;}
add interface=wlan1
/ routing ospf network
:foreach i in [/routing ospf network find network=10.138.42.160/27] do={/routing ospf network remove $i;}
add network=10.138.42.160/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan1] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan1 ranges=10.138.42.167-10.138.42.190
:foreach i in [/ip dhcp-server find name=dhcp-wlan1] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan1 interface=wlan1 address-pool=dhcp-wlan1 disabled=no
:foreach i in [/ip dhcp-server network find address="10.138.42.160/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.138.42.160/27 gateway=10.138.42.161 domain=guifi.net comment=dhcp-wlan1
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.138.42.162 mac-address=00:16:01:84:97:DA client-id=SBGIreneRadio1 server=dhcp-wlan1
add address=10.138.42.163 mac-address=ff:ff:ff:ff:ff:ff client-id=SBGXT server=dhcp-wlan1
add address=10.138.42.164 mac-address=00:15:6D:AC:DE:A2 client-id=SBGguiteresRd1 server=dhcp-wlan1
add address=10.138.42.165 mac-address=00:15:6D:A8:C1:67 client-id=SBGgquirzeRd1 server=dhcp-wlan1
add address=10.138.42.166 mac-address=00:27:22:C2:DE:B6 client-id=SBGJoseLuisRd1 server=dhcp-wlan1
add address=10.138.42.167 mac-address=00:15:6D:1B:35:16 client-id=SBGAlbaRd1 server=dhcp-wlan1
add address=10.138.42.168 mac-address=00:16:B6:DA:13:46 client-id=SBGMatiRadio1 server=dhcp-wlan1
add address=10.138.42.169 mac-address=00:18:F8:71:3C:73 client-id=SBGLRqlmRd1 server=dhcp-wlan1
add address=10.138.42.170 mac-address=00:16:B6:39:79:C6 client-id=SBGgJoanetRadio1 server=dhcp-wlan1
add address=10.138.42.172 mac-address=00:16:01:AD:D2:4C client-id=SBGMartaRadio1 server=dhcp-wlan1
add address=10.138.42.173 mac-address=00:18:F8:71:3C:73 client-id=SBGlrsRd1 server=dhcp-wlan1
add address=10.138.42.174 mac-address=00:16:B6:39:79:B8 client-id=SBGpisosRadio1 server=dhcp-wlan1
add address=10.138.42.175 mac-address=00:16:01:AF:D7:28 client-id=SBGcasetadelvilarRadio1 server=dhcp-wlan1
add address=10.138.42.176 mac-address=00:16:01:AF:F1:9C client-id=SBGassumptaRadio1 server=dhcp-wlan1
add address=10.138.42.177 mac-address=00:16:01:AD:04:E2 client-id=SBGVilaroRd2 server=dhcp-wlan1
add address=10.138.42.178 mac-address=00:00:00:00:00:00 client-id=SBGCalSalesRd1 server=dhcp-wlan1
add address=10.138.42.179 mac-address=00:16:01:F2:2F:9A client-id=SBGSaidaRadio1 server=dhcp-wlan1
add address=10.138.42.180 mac-address=00:16:01:F2:13:88 client-id=SBGsergiRadio1 server=dhcp-wlan1
add address=10.138.42.181 mac-address=00:16:01:F2:14:52 client-id=SBGSantiRadio1 server=dhcp-wlan1
add address=10.138.42.182 mac-address=00:16:01:F2:13:D0 client-id=SBGcaltravassetRadio1 server=dhcp-wlan1
add address=10.138.42.184 mac-address=00:15:6D:5E:83:CD client-id=SBGAguilarRd1 server=dhcp-wlan1
add address=10.138.42.185 mac-address=00:16:01:F2:2A:36 client-id=SBGCalVinyesRadio1 server=dhcp-wlan1
add address=10.138.42.186 mac-address=00:16:01:F2:40:7B client-id=SobremuntPortellesRd2 server=dhcp-wlan1
add address=10.138.42.189 mac-address=00:15:6D:A7:B8:94 client-id=SBGgcutriRd3 server=dhcp-wlan1
add address=10.138.42.190 mac-address=00:15:6D:E0:93:A4 client-id=SBGXPTRadio2 server=dhcp-wlan1
#
:delay 1
#
# Radio#: 1 SBGTorreAP5Nord
/interface wireless set wlan2 name="wlan2" \
radio-name="SBGTorreAP5Nord" mode=ap-bridge ssid="guifi.net-SBGTorreAP5Nord" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=20 \
frequency=5200 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsSBGTorreAP5Nord
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan2] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_SBGAjuntamentST1" master-interface=wlan2 wds-address=00:0C:42:0C:1A:CF disabled=no
/ ip address add address=172.25.2.122/30 network=172.25.2.120 broadcast=172.25.2.123 interface=wds_SBGAjuntamentST1 disabled=no comment="wds_SBGAjuntamentST1"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_SBGAjuntamentST1] do={/routing ospf interface remove $i;}
add interface=wds_SBGAjuntamentST1
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.2.120/30] do={/routing ospf network remove $i;}
add network=172.25.2.120/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=SBGAjuntamentST1] do={/routing bgp peer remove $i;}
add name="SBGAjuntamentST1" instance=default remote-address=172.25.2.121 remote-as=21715 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.138.30.193/27"] do={remove $i}
/ ip address add address=10.138.30.193/27 network=10.138.30.192 broadcast=10.138.30.223 interface=wlan2 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.138.30.192/27] do={/routing bgp network remove $i;}
add network=10.138.30.192/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan2] do={/routing ospf interface remove $i;}
add interface=wlan2
/ routing ospf network
:foreach i in [/routing ospf network find network=10.138.30.192/27] do={/routing ospf network remove $i;}
add network=10.138.30.192/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan2] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan2 ranges=10.138.30.199-10.138.30.222
:foreach i in [/ip dhcp-server find name=dhcp-wlan2] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan2 interface=wlan2 address-pool=dhcp-wlan2 disabled=no
:foreach i in [/ip dhcp-server network find address="10.138.30.192/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.138.30.192/27 gateway=10.138.30.193 domain=guifi.net comment=dhcp-wlan2
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.138.30.194 mac-address=00:0C:42:FF:31:15 client-id=SBGMBallusRd1 server=dhcp-wlan2
add address=10.138.30.195 mac-address=99:99:99:99:99:99 client-id=SbgVilaroRd1 server=dhcp-wlan2
add address=10.138.30.196 mac-address=99:99:99:99:99:99 client-id=SbgSBallusRd1 server=dhcp-wlan2
add address=10.138.30.197 mac-address=D4:CA:6D:C3:81:6F client-id=SbgABallusRd1 server=dhcp-wlan2
add address=10.138.30.198 mac-address=00:00:00:00:00:00 client-id=SBGAbdelkaderTRd1 server=dhcp-wlan2
add address=10.138.30.199 mac-address=00:00:00:00:00:00 client-id=SBGFarmaciolaRd1 server=dhcp-wlan2
add address=10.138.30.200 mac-address=00:00:00:00:00:00 client-id=SBGAjuntamentFW server=dhcp-wlan2
#
:delay 1
#
# Radio#: 2 SBGTorreAPSudEst
/interface wireless set wlan3 name="wlan3" \
radio-name="SBGTorreAPSudEst" mode=ap-bridge ssid="guifi.net-SBGTorreAPSudEst" \
band="2ghz-b" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
frequency=2442 \
dfs-mode=none \
antenna-mode=ant-b wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.138.42.193/27"] do={remove $i}
/ ip address add address=10.138.42.193/27 network=10.138.42.192 broadcast=10.138.42.223 interface=wlan3 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.138.42.192/27] do={/routing bgp network remove $i;}
add network=10.138.42.192/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan3] do={/routing ospf interface remove $i;}
add interface=wlan3
/ routing ospf network
:foreach i in [/routing ospf network find network=10.138.42.192/27] do={/routing ospf network remove $i;}
add network=10.138.42.192/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan3] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan3 ranges=10.138.42.199-10.138.42.222
:foreach i in [/ip dhcp-server find name=dhcp-wlan3] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan3 interface=wlan3 address-pool=dhcp-wlan3 disabled=no
:foreach i in [/ip dhcp-server network find address="10.138.42.192/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.138.42.192/27 gateway=10.138.42.193 domain=guifi.net comment=dhcp-wlan3
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.138.42.194 mac-address=99:99:99:99:99:9A client-id=SBGConxiRd2 server=dhcp-wlan3
add address=10.138.42.195 mac-address=00:15:6D:82:2F:F4 client-id=SBGMagdaRd1 server=dhcp-wlan3
add address=10.138.42.196 mac-address=00:00:00:00:00:00 client-id=SBGRocanegraRd1 server=dhcp-wlan3
add address=10.138.42.198 mac-address=00:16:01:AF:AE:68 client-id=SBGIbraRadio1 server=dhcp-wlan3
add address=10.138.42.205 mac-address=FF:FF:10:00:00:00 client-id=SBGVilamalaRd1 server=dhcp-wlan3
add address=10.138.42.207 mac-address=00:16:B6:39:79:BD client-id=SBGelisabetRd1 server=dhcp-wlan3
add address=10.138.42.210 mac-address=00:15:6D:60:63:62 client-id=SBGDidacRd1 server=dhcp-wlan3
#
:delay 1
#
# Radio#: 3 SBGTorreAP5Est
/interface wireless set wlan4 name="wlan4" \
radio-name="SBGTorreAP5Est" mode=ap-bridge ssid="guifi.net-SBGTorreAP5Est" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=20 \
frequency=5180 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.138.30.97/27"] do={remove $i}
/ ip address add address=10.138.30.97/27 network=10.138.30.96 broadcast=10.138.30.127 interface=wlan4 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.138.30.96/27] do={/routing bgp network remove $i;}
add network=10.138.30.96/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan4] do={/routing ospf interface remove $i;}
add interface=wlan4
/ routing ospf network
:foreach i in [/routing ospf network find network=10.138.30.96/27] do={/routing ospf network remove $i;}
add network=10.138.30.96/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan4] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan4 ranges=10.138.30.103-10.138.30.126
:foreach i in [/ip dhcp-server find name=dhcp-wlan4] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan4 interface=wlan4 address-pool=dhcp-wlan4 disabled=no
:foreach i in [/ip dhcp-server network find address="10.138.30.96/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.138.30.96/27 gateway=10.138.30.97 domain=guifi.net comment=dhcp-wlan4
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.138.30.98 mac-address=99:99:99:99:99:9A client-id=SbgLaMasiaRd1 server=dhcp-wlan4
add address=10.138.30.99 mac-address=00:0C:42:17:56:D1 client-id=SbgEscolesRd1 server=dhcp-wlan4
add address=10.138.30.100 mac-address=D4:CA:6D:C5:38:25 client-id=SBGPerezRd1 server=dhcp-wlan4
add address=10.138.30.101 mac-address=00:00:00:00:00:00 client-id=SBGgamezRadio1 server=dhcp-wlan4
add address=10.138.30.102 mac-address=00:0C:42:7C:25:0B client-id=SBGRoserRd1 server=dhcp-wlan4
add address=10.138.30.103 mac-address=00:00:00:00:00:00 client-id=SbgrefusolRd1 server=dhcp-wlan4
add address=10.138.30.104 mac-address=E4:8D:8C:90:D3:5B client-id=SbgJRomeroRd1 server=dhcp-wlan4
add address=10.138.30.106 mac-address=00:00:00:00:00:00 client-id=SBGRBVicRd1 server=dhcp-wlan4
add address=10.138.30.107 mac-address=00:00:00:00:00:00 client-id=SBGJoanRamonRd1 server=dhcp-wlan4
#
:delay 1
#
# Radio#: 4 SBGTorreAP5Oest
/interface wireless set wlan5 name="wlan5" \
radio-name="SBGTorreAP5Oest" mode=ap-bridge ssid="guifi.net-SBGTorreAP5Oest" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.138.42.33/27"] do={remove $i}
/ ip address add address=10.138.42.33/27 network=10.138.42.32 broadcast=10.138.42.63 interface=wlan5 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.138.42.32/27] do={/routing bgp network remove $i;}
add network=10.138.42.32/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan5] do={/routing ospf interface remove $i;}
add interface=wlan5
/ routing ospf network
:foreach i in [/routing ospf network find network=10.138.42.32/27] do={/routing ospf network remove $i;}
add network=10.138.42.32/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan5] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan5 ranges=10.138.42.39-10.138.42.62
:foreach i in [/ip dhcp-server find name=dhcp-wlan5] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan5 interface=wlan5 address-pool=dhcp-wlan5 disabled=no
:foreach i in [/ip dhcp-server network find address="10.138.42.32/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.138.42.32/27 gateway=10.138.42.33 domain=guifi.net comment=dhcp-wlan5
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.138.42.34 mac-address=99:99:99:99:99:9A client-id=SBGlatalaiaRd2 server=dhcp-wlan5
add address=10.138.42.35 mac-address=D4:CA:6D:CB:F9:57 client-id=SBGTaharBRd1 server=dhcp-wlan5
add address=10.138.42.36 mac-address=D4:CA:6D:47:9E:95 client-id=SBGMasVilasecaRd2 server=dhcp-wlan5
add address=10.138.42.38 mac-address=4C:5E:0C:0F:03:81 client-id=SBGNou16Rd1 server=dhcp-wlan5
add address=10.138.42.39 mac-address=00:15:6D:92:2F:F0 client-id=SBGJFarresRd1 server=dhcp-wlan5
add address=10.138.42.40 mac-address=00:00:00:00:00:00 client-id=SBGJMRd1 server=dhcp-wlan5
add address=10.138.42.41 mac-address=FF:FF:FF:FF:FF:FF client-id=SBGMmolasRd3 server=dhcp-wlan5
add address=10.138.42.42 mac-address=D4:CA:6D:FF:91:CD client-id=SBGTarikARd1 server=dhcp-wlan5
add address=10.138.42.44 mac-address=4C:5E:0C:7C:EF:D7 client-id=SBGCParesRd1 server=dhcp-wlan5
add address=10.138.42.45 mac-address=D4:CA:6D:D0:13:F3 client-id=SBGCerezoRd2 server=dhcp-wlan5
add address=10.138.42.46 mac-address=00:00:00:00:00:00 client-id=SBGPasseigGrau10Rd1 server=dhcp-wlan5
add address=10.138.42.47 mac-address=4C:5E:0C:BD:EE:7B client-id=SBGvilasecaRd2 server=dhcp-wlan5
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.138.148.65 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.138.148.65" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.138.148.65"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=5613 router-id=10.138.148.65 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf instance set default name=default router-id=10.138.148.65 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 5613-SBGTorreAPs executed."
/