# Generat per a:
# RouterOSv6.x
:log info "Unsolclic for 75364-VLLOles-RB going to be executed."
#
# Configuration for RouterOSv6.x
# Trasto: 75364-VLLOles-RB
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
# a.Winbox (with Linux, wine required)
# b.Terminal (telnet, ssh...)
# Then execute the script with:
# > /system script run script_name
# 2.-Fitxer importat:
# Desa aquesta "sortida" a un fitxer, després puja'l al router
# fent servir FTP amb un nom de l'estil "script_name.rsc".
# (note, l'extensió ".rsc" es un requisit)
# Executa el fitxer importat amb la comanda:
# > /import script_name
# 3.-Telnet copia i enganxar:
# Open a terminal session, and cut&paste this output
# directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
# according in how did you connect the cable to the miniPCI. Keep the
# power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
# (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
# to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
# the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=VLLOles-RB
#
# DNS (client & server cache) zone: 87709
:delay 1
#
# NTP (client & server cache) zone: 87709
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="VLLOles" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
:delay 1
#
# Radio#: 0 VLLOles-Pentanes
/interface wireless set wlan1 name="wlan1" \
radio-name="VLLOles-Pentanes" mode=ap-bridge ssid="guifi.net-VLLOles-Pentanes" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=25 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsVLLOles-Pentanes
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_VLLPentanesRB" master-interface=wlan1 wds-address=00:00:00:00:00:00 disabled=no
/ ip address add address=172.16.13.62/29 network=172.16.13.56 broadcast=172.16.13.63 interface=wds_VLLPentanesRB disabled=no comment="wds_VLLPentanesRB"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_VLLPentanesRB] do={/routing ospf interface remove $i;}
add interface=wds_VLLPentanesRB
/ routing ospf network
:foreach i in [/routing ospf network find network=172.16.13.56/29] do={/routing ospf network remove $i;}
add network=172.16.13.56/29 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=VLLPentanesRB] do={/routing bgp peer remove $i;}
add name="VLLPentanesRB" instance=default remote-address=172.16.13.57 remote-as=75580 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
#
:delay 1
#
# Radio#: 1 VLLOles-Enlaz2
/interface wireless set wlan2 name="wlan2" \
radio-name="VLLOles-Enlaz2" mode=ap-bridge ssid="guifi.net-VLLOles-Enlaz2" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=25 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
#
# Radio#: 2 VLLOles-APSE
/interface wireless set wlan3 name="wlan3" \
radio-name="VLLOles-APSE" mode=ap-bridge ssid="guifi.net-VLLOles-APSE" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=16 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.64.39.65/27"] do={remove $i}
/ ip address add address=10.64.39.65/27 network=10.64.39.64 broadcast=10.64.39.95 interface=wlan3 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.64.39.64/27] do={/routing bgp network remove $i;}
add network=10.64.39.64/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan3] do={/routing ospf interface remove $i;}
add interface=wlan3
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.39.64/27] do={/routing ospf network remove $i;}
add network=10.64.39.64/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan3] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan3 ranges=10.64.39.71-10.64.39.94
:foreach i in [/ip dhcp-server find name=dhcp-wlan3] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan3 interface=wlan3 address-pool=dhcp-wlan3 disabled=no
:foreach i in [/ip dhcp-server network find address="10.64.39.64/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.64.39.64/27 gateway=10.64.39.65 domain=guifi.net comment=dhcp-wlan3
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.64.39.66 mac-address=00:00:00:00:00:00 client-id=VLLOlesbisAPSE server=dhcp-wlan3
add address=10.64.39.67 mac-address=B4:FB:E4:A2:80:93 client-id=VLLLaLlata7PBEM5 server=dhcp-wlan3
add address=10.64.39.68 mac-address=04:18:D6:26:23:C9 client-id=VLLCortijoElMontePBEM5 server=dhcp-wlan3
add address=10.64.39.69 mac-address=FA:44:D9:E7:62:16 client-id=VLLVCSLineru26PBEM5 server=dhcp-wlan3
add address=10.64.39.70 mac-address=FC:EC:DA:6A:C1:4C client-id=VLLVCSOlesBMarina3PBEM5 server=dhcp-wlan3
add address=10.64.39.71 mac-address=44:D9:E7:BA:93:15 client-id=VLLLinero34PBEM5 server=dhcp-wlan3
add address=10.64.39.72 mac-address=44:D9:E7:D4:BA:12 client-id=VLLVCSOles40PBEM5 server=dhcp-wlan3
add address=10.64.39.73 mac-address=B4:FB:E4:62:3B:3D client-id=VLLOles1PBEM5 server=dhcp-wlan3
add address=10.64.39.74 mac-address=F0:9F:C2:5E:FE:2C client-id=VLLVCSOlesSMarina41PBEM5 server=dhcp-wlan3
add address=10.64.39.75 mac-address=04:18:D6:26:19:E4 client-id=VLLVCSLlineru31PBEM5 server=dhcp-wlan3
add address=10.64.39.76 mac-address=68:D7:9A:BA:68:94 client-id=VLLLinero1350PBEM5 server=dhcp-wlan3
add address=10.64.39.77 mac-address=FA:BA:DA:FA:BA:DA client-id=VLLSantaMarina21PBEM5 server=dhcp-wlan3
add address=10.64.39.78 mac-address=AC:8B:A9:C0:F5:27 client-id=VLLElMonte3LBAC server=dhcp-wlan3
#
:delay 1
#
# Radio#: 3 VLLOles-Local
/interface wireless set wlan4 name="wlan4" \
radio-name="VLLOles-Local" mode=ap-bridge ssid="guifi.net-VLLOles-Local" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.64.39.17/28"] do={remove $i}
/ ip address add address=10.64.39.17/28 network=10.64.39.16 broadcast=10.64.39.31 interface=wlan4 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.64.39.16/28] do={/routing bgp network remove $i;}
add network=10.64.39.16/28 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan4] do={/routing ospf interface remove $i;}
add interface=wlan4
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.39.16/28] do={/routing ospf network remove $i;}
add network=10.64.39.16/28 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan4] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan4 ranges=10.64.39.23-10.64.39.30
:foreach i in [/ip dhcp-server find name=dhcp-wlan4] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan4 interface=wlan4 address-pool=dhcp-wlan4 disabled=no
:foreach i in [/ip dhcp-server network find address="10.64.39.16/28"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.64.39.16/28 gateway=10.64.39.17 domain=guifi.net comment=dhcp-wlan4
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.64.39.18 mac-address=00:00:00:00:00:00 client-id=VLLVCSOlesCasaMinaChigre server=dhcp-wlan4
add address=10.64.39.19 mac-address=00:00:00:00:00:00 client-id=VLLVCSOlesCasaMinaCasa server=dhcp-wlan4
add address=10.64.39.20 mac-address=00:00:00:00:00:00 client-id=VLLVCSOlesBMarina1TPLINK server=dhcp-wlan4
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.39.0/28] do={/routing ospf network remove $i;}
add network=10.64.39.0/28 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=VLLOlesPentanes] do={/routing bgp peer remove $i;}
add name="VLLOlesPentanes" instance=default remote-address=10.64.39.2 remote-as=75365 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.39.0/28] do={/routing ospf network remove $i;}
add network=10.64.39.0/28 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=VLLOlesAPSE] do={/routing bgp peer remove $i;}
add name="VLLOlesAPSE" instance=default remote-address=10.64.39.8 remote-as=75369 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="10.64.39.1/28"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.64.39.1/28 network=10.64.39.0 broadcast=10.64.39.15 interface=Lan disabled=no comment="VLLOlesPentanes,VLLOlesAPSE"
:foreach i in [/ip address find address="10.64.39.0/24"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.64.39.0/24 network=10.64.39.0 broadcast=10.64.39.255 interface=Reserva disabled=no comment="VLLOlesPentanes,VLLOlesAPSE"
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.64.39.1 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.64.39.1" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.64.39.1"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=75364 router-id=10.64.39.1 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf instance set default name=default router-id=10.64.39.1 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 75364-VLLOles-RB executed."
/