# Generat per a:
# RouterOSv6.x
:log info "Unsolclic for 85064-LLNPuronTDT-RB going to be executed."
#
# Configuration for RouterOSv6.x
# Trasto: 85064-LLNPuronTDT-RB
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
# a.Winbox (with Linux, wine required)
# b.Terminal (telnet, ssh...)
# Then execute the script with:
# > /system script run script_name
# 2.-Fitxer importat:
# Desa aquesta "sortida" a un fitxer, després puja'l al router
# fent servir FTP amb un nom de l'estil "script_name.rsc".
# (note, l'extensió ".rsc" es un requisit)
# Executa el fitxer importat amb la comanda:
# > /import script_name
# 3.-Telnet copia i enganxar:
# Open a terminal session, and cut&paste this output
# directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
# according in how did you connect the cable to the miniPCI. Keep the
# power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
# (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
# to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
# the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=LLNPuronTDT-RB
#
# DNS (client & server cache) zone: 88054
:delay 1
#
# NTP (client & server cache) zone: 88054
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="LLNPuronTDT" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
:delay 1
#
# Radio#: 0 LLNPuronTDT-Resquilone
/interface wireless set wlan1 name="wlan1" \
radio-name="LLNPuronTDT-Resquilone" mode=ap-bridge ssid="guifi.net-LLNPuronTDT-Resquilone" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsLLNPuron-Resquilones
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_LLNResquilonesRB" master-interface=wlan1 wds-address=00:00:00:00:00:00 disabled=no
/ ip address add address=172.16.15.45/30 network=172.16.15.44 broadcast=172.16.15.47 interface=wds_LLNResquilonesRB disabled=no comment="wds_LLNResquilonesRB"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_LLNResquilonesRB] do={/routing ospf interface remove $i;}
add interface=wds_LLNResquilonesRB
/ routing ospf network
:foreach i in [/routing ospf network find network=172.16.15.44/30] do={/routing ospf network remove $i;}
add network=172.16.15.44/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=LLNResquilonesRB] do={/routing bgp peer remove $i;}
add name="LLNResquilonesRB" instance=default remote-address=172.16.15.46 remote-as=94130 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
#
# Radio#: 1 LLNPuronTDT-Golf
/interface wireless set wlan2 name="wlan2" \
radio-name="LLNPuronTDT-Golf" mode=ap-bridge ssid="guifi.net-LLNPuronTDT-Golf" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsLLNPuron-Golf
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan2] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_LLNGolfRB" master-interface=wlan2 wds-address=00:00:00:00:00:00 disabled=no
/ ip address add address=172.16.17.177/30 network=172.16.17.176 broadcast=172.16.17.179 interface=wds_LLNGolfRB disabled=no comment="wds_LLNGolfRB"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_LLNGolfRB] do={/routing ospf interface remove $i;}
add interface=wds_LLNGolfRB
/ routing ospf network
:foreach i in [/routing ospf network find network=172.16.17.176/30] do={/routing ospf network remove $i;}
add network=172.16.17.176/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=LLNGolfRB] do={/routing bgp peer remove $i;}
add name="LLNGolfRB" instance=default remote-address=172.16.17.178 remote-as=101130 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
#
# Radio#: 2 LLNPuronTDT-PicoLLuere
/interface wireless set wlan3 name="wlan3" \
radio-name="LLNPuronTDT-PicoLLuere" mode=ap-bridge ssid="guifi.net-LLNPuronTDT-PicoLLuere" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsLLNPuron-PicoLLueres
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan3] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_PNMLLRBPicoLlueresRB" master-interface=wlan3 wds-address=00:00:00:00:00:00 disabled=no
/ ip address add address=172.16.6.58/30 network=172.16.6.56 broadcast=172.16.6.59 interface=wds_PNMLLRBPicoLlueresRB disabled=no comment="wds_PNMLLRBPicoLlueresRB"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_PNMLLRBPicoLlueresRB] do={/routing ospf interface remove $i;}
add interface=wds_PNMLLRBPicoLlueresRB
/ routing ospf network
:foreach i in [/routing ospf network find network=172.16.6.56/30] do={/routing ospf network remove $i;}
add network=172.16.6.56/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=PNMLLRBPicoLlueresRB] do={/routing bgp peer remove $i;}
add name="PNMLLRBPicoLlueresRB" instance=default remote-address=172.16.6.57 remote-as=108266 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
#
# Radio#: 3 LLNPuronTDT-APE
/interface wireless set wlan4 name="wlan4" \
radio-name="LLNPuronTDT-APE" mode=ap-bridge ssid="guifi.net-LLNPuronTDT-APE" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.64.106.65/27"] do={remove $i}
/ ip address add address=10.64.106.65/27 network=10.64.106.64 broadcast=10.64.106.95 interface=wlan4 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.64.106.64/27] do={/routing bgp network remove $i;}
add network=10.64.106.64/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan4] do={/routing ospf interface remove $i;}
add interface=wlan4
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.106.64/27] do={/routing ospf network remove $i;}
add network=10.64.106.64/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan4] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan4 ranges=10.64.106.71-10.64.106.94
:foreach i in [/ip dhcp-server find name=dhcp-wlan4] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan4 interface=wlan4 address-pool=dhcp-wlan4 disabled=no
:foreach i in [/ip dhcp-server network find address="10.64.106.64/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.64.106.64/27 gateway=10.64.106.65 domain=guifi.net comment=dhcp-wlan4
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.64.106.66 mac-address=00:00:00:00:00:00 client-id=LLNPuronTDTbisAPE server=dhcp-wlan4
add address=10.64.106.67 mac-address=FC:EC:DA:5C:73:4F client-id=LLNSPuronSerenaCandalPBEM5 server=dhcp-wlan4
add address=10.64.106.68 mac-address=00:27:22:F4:FF:63 client-id=LLNSPuronArneru15PBEM5 server=dhcp-wlan4
add address=10.64.106.69 mac-address=18:E8:29:8A:AB:32 client-id=LLNSPuronCampanariuPBEM5 server=dhcp-wlan4
add address=10.64.106.70 mac-address=FC:EC:DA:6A:C2:38 client-id=LLNSPuron27PBEM5 server=dhcp-wlan4
add address=10.64.106.71 mac-address=18:E8:29:80:A2:A4 client-id=LLNMerodio3849LBAC server=dhcp-wlan4
add address=10.64.106.72 mac-address=B4:FB:E4:62:35:99 client-id=LLNSLaBoleraVieja21PBEM5 server=dhcp-wlan4
add address=10.64.106.73 mac-address=B4:FB:E4:58:4C:59 client-id=LLNLaZoreradeArribaPBEM5 server=dhcp-wlan4
add address=10.64.106.74 mac-address=B4:FB:E4:58:47:F6 client-id=LLNElCanalexuPBEM5 server=dhcp-wlan4
add address=10.64.106.75 mac-address=B4:FB:E4:58:4F:74 client-id=LLNLaZorera2202PBEM5 server=dhcp-wlan4
add address=10.64.106.76 mac-address=B4:FB:E4:58:50:1E client-id=LLNElCuevu24PBEM5 server=dhcp-wlan4
add address=10.64.106.77 mac-address=F0:9F:C2:98:8E:54 client-id=LLNPuron40PBEM5 server=dhcp-wlan4
add address=10.64.106.78 mac-address=68:D7:9A:96:41:77 client-id=LLNCasaRotaPBEM5 server=dhcp-wlan4
add address=10.64.106.79 mac-address=68:D7:9A:96:4B:B3 client-id=LLNLaZorera42PBEM5 server=dhcp-wlan4
add address=10.64.106.80 mac-address=68:D7:9A:96:4A:B0 client-id=LLNPuron2702PBEM5 server=dhcp-wlan4
add address=10.64.106.81 mac-address=68:D7:9A:96:4D:B0 client-id=LLNCorraldeAbajo3PBEM5 server=dhcp-wlan4
add address=10.64.106.82 mac-address=18:E8:29:D8:C0:33 client-id=LLNLaZorera2822PBEM5 server=dhcp-wlan4
add address=10.64.106.83 mac-address=F4:92:BF:E8:2A:A5 client-id=LLNLaBoleraViejaPBEM5 server=dhcp-wlan4
add address=10.64.106.84 mac-address=F0:9F:C2:4A:33:C8 client-id=LLNBoleradelosPicosPBEM5 server=dhcp-wlan4
add address=10.64.106.85 mac-address=FC:EC:DA:C8:F8:57 client-id=LLNPuron15PBEM5 server=dhcp-wlan4
add address=10.64.106.86 mac-address=18:E8:29:D8:C0:FD client-id=LLNElCorraldeAbajo15PBEM5 server=dhcp-wlan4
add address=10.64.106.87 mac-address=18:E8:29:D8:B3:1E client-id=LLNLosPicosPBEM5 server=dhcp-wlan4
add address=10.64.106.88 mac-address=18:E8:29:D8:B2:29 client-id=LLNPuron3192PBEM5 server=dhcp-wlan4
add address=10.64.106.89 mac-address=60:22:32:DE:C2:A8 client-id=LLNPuron3499LBAC server=dhcp-wlan4
add address=10.64.106.90 mac-address=68:D7:9A:94:85:30 client-id=LLNPuron2854LBAC server=dhcp-wlan4
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.106.0/28] do={/routing ospf network remove $i;}
add network=10.64.106.0/28 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=LLNPuronTDTResquilones] do={/routing bgp peer remove $i;}
add name="LLNPuronTDTResquilones" instance=default remote-address=10.64.106.2 remote-as=85065 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.106.0/28] do={/routing ospf network remove $i;}
add network=10.64.106.0/28 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=LLNPuronTDTGolf] do={/routing bgp peer remove $i;}
add name="LLNPuronTDTGolf" instance=default remote-address=10.64.106.3 remote-as=95019 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.106.0/28] do={/routing ospf network remove $i;}
add network=10.64.106.0/28 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=LLNPuronTDTPicoLlueres] do={/routing bgp peer remove $i;}
add name="LLNPuronTDTPicoLlueres" instance=default remote-address=10.64.106.4 remote-as=95020 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.106.0/28] do={/routing ospf network remove $i;}
add network=10.64.106.0/28 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=LLNPuronTDTAPE] do={/routing bgp peer remove $i;}
add name="LLNPuronTDTAPE" instance=default remote-address=10.64.106.7 remote-as=95023 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
:foreach i in [/ip address find address="10.64.106.1/28"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.64.106.1/28 network=10.64.106.0 broadcast=10.64.106.15 interface=Lan disabled=no comment="LLNPuronTDTResquilones,LLNPuronTDTGolf,LLNPuronTDTPicoLlueres,LLNPuronTDTAPE"
:foreach i in [/ip address find address="10.64.106.17/28"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.64.106.17/28 network=10.64.106.16 broadcast=10.64.106.31 interface=Local disabled=no comment="LLNPuronTDTResquilones,LLNPuronTDTGolf,LLNPuronTDTPicoLlueres,LLNPuronTDTAPE"
:foreach i in [/ip address find address="10.64.106.0/24"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.64.106.0/24 network=10.64.106.0 broadcast=10.64.106.255 interface=Reserva disabled=no comment="LLNPuronTDTResquilones,LLNPuronTDTGolf,LLNPuronTDTPicoLlueres,LLNPuronTDTAPE"
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.64.106.1 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.64.106.1" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.64.106.1"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=85064 router-id=10.64.106.1 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf instance set default name=default router-id=10.64.106.1 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 85064-LLNPuronTDT-RB executed."
/