# Generat per a:
# RouterOSv5.x
:log info "Unsolclic for 86175-CLNLaRiera-RB going to be executed."
#
# Configuration for RouterOSv5.x
# Device: 86175-CLNLaRiera-RB
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
# a.Winbox (with Linux, wine required)
# b.Terminal (telnet, ssh...)
# Then execute the script with:
# > /system script run script_name
# 2.-Fitxer importat:
# Desa aquesta "sortida" a un fitxer, després puja'l al router
# fent servir FTP amb un nom de l'estil "script_name.rsc".
# (note, l'extensió ".rsc" es un requisit)
# Executa el fitxer importat amb la comanda:
# > /import script_name
# 3.-Telnet copia i enganxar:
# Open a terminal session, and cut&paste this output
# directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
# according in how did you connect the cable to the miniPCI. Keep the
# power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
# (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
# to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
# the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=CLNLaRiera-RB
#
# DNS (client & server cache) zone: 87662
:delay 1
#
# NTP (client & server cache) zone: 87662
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="CLNLaRiera" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
:delay 1
#
# Radio#: 0 CLNLaRiera-LaRieraTDT
/interface wireless set wlan1 name="wlan1" \
radio-name="CLNLaRiera-LaRieraTDT" mode=ap-bridge ssid="guifi.net-CLNLaRiera-LaRieraTDT" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=25 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsCLNLaRiera-LaRieraTDT
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_CLNLaRieraTDTRB" master-interface=wlan1 wds-address=00:00:00:00:00:00 disabled=no
/ ip address add address=172.16.12.186/30 network=172.16.12.184 broadcast=172.16.12.187 interface=wds_CLNLaRieraTDTRB disabled=no comment="wds_CLNLaRieraTDTRB"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_CLNLaRieraTDTRB] do={/routing ospf interface remove $i;}
add interface=wds_CLNLaRieraTDTRB
/ routing ospf network
:foreach i in [/routing ospf network find network=172.16.12.184/30] do={/routing ospf network remove $i;}
add network=172.16.12.184/30 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=CLNLaRieraTDTRB] do={/routing bgp peer remove $i;}
add name="CLNLaRieraTDTRB" instance=default remote-address=172.16.12.185 remote-as=93461 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
#
:delay 1
#
# Radio#: 1 CLNLaRiera-APNE
/interface wireless set wlan2 name="wlan2" \
radio-name="CLNLaRiera-APNE" mode=ap-bridge ssid="guifi.net-CLNLaRiera-APNE" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=16 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.64.55.33/27"] do={remove $i}
/ ip address add address=10.64.55.33/27 network=10.64.55.32 broadcast=10.64.55.63 interface=wlan2 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.64.55.32/27] do={/routing bgp network remove $i;}
add network=10.64.55.32/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan2] do={/routing ospf interface remove $i;}
add interface=wlan2
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.55.32/27] do={/routing ospf network remove $i;}
add network=10.64.55.32/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan2] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan2 ranges=10.64.55.39-10.64.55.62
:foreach i in [/ip dhcp-server find name=dhcp-wlan2] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan2 interface=wlan2 address-pool=dhcp-wlan2 disabled=no
:foreach i in [/ip dhcp-server network find address="10.64.55.32/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.64.55.32/27 gateway=10.64.55.33 domain=guifi.net comment=dhcp-wlan2
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.64.55.34 mac-address=00:00:00:00:00:00 client-id=CLNLaRierabisAPNE server=dhcp-wlan2
add address=10.64.55.38 mac-address=80:2A:A8:6E:71:9A client-id=CLNGASales131PBEM5 server=dhcp-wlan2
add address=10.64.55.40 mac-address=18:E8:29:34:9C:82 client-id=CLNSales222PBEM5 server=dhcp-wlan2
#
:delay 1
#
# Radio#: 2 CLNLaRiera-APSE
/interface wireless set wlan3 name="wlan3" \
radio-name="CLNLaRiera-APSE" mode=ap-bridge ssid="guifi.net-CLNLaRiera-APSE" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=16 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.64.55.65/27"] do={remove $i}
/ ip address add address=10.64.55.65/27 network=10.64.55.64 broadcast=10.64.55.95 interface=wlan3 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.64.55.64/27] do={/routing bgp network remove $i;}
add network=10.64.55.64/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan3] do={/routing ospf interface remove $i;}
add interface=wlan3
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.55.64/27] do={/routing ospf network remove $i;}
add network=10.64.55.64/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan3] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan3 ranges=10.64.55.71-10.64.55.94
:foreach i in [/ip dhcp-server find name=dhcp-wlan3] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan3 interface=wlan3 address-pool=dhcp-wlan3 disabled=no
:foreach i in [/ip dhcp-server network find address="10.64.55.64/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.64.55.64/27 gateway=10.64.55.65 domain=guifi.net comment=dhcp-wlan3
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.64.55.66 mac-address=00:00:00:00:00:00 client-id=CLNLaRierabisAPSE server=dhcp-wlan3
add address=10.64.55.67 mac-address=80:2A:A8:7E:4F:B9 client-id=CNLLaRiera79PBEM5 server=dhcp-wlan3
add address=10.64.55.68 mac-address=F0:9F:C2:52:BD:6F client-id=CLNGALaRieraNozal119PBEM5 server=dhcp-wlan3
add address=10.64.55.69 mac-address=F0:9F:C2:40:C7:50 client-id=CLNGLaRiera118PBEM5 server=dhcp-wlan3
add address=10.64.55.70 mac-address=F4:E2:C6:34:91:83 client-id=CLNLaRiera151LBAC server=dhcp-wlan3
add address=10.64.55.71 mac-address=78:8A:20:EE:95:67 client-id=CLNGLaRieraElMolinoPBEM5 server=dhcp-wlan3
add address=10.64.55.73 mac-address=F0:9F:C2:84:9E:6D client-id=CLNGLaRieraNozal105PBEM5 server=dhcp-wlan3
add address=10.64.55.74 mac-address=B4:FB:E4:58:4F:CA client-id=CLNLaNozaleda11PBEM5 server=dhcp-wlan3
add address=10.64.55.75 mac-address=FC:EC:DA:C8:F5:FC client-id=CLNLaPride25PBEM5 server=dhcp-wlan3
add address=10.64.55.76 mac-address=18:E8:29:80:F2:FD client-id=CLNElFoncielluPBEM5 server=dhcp-wlan3
add address=10.64.55.77 mac-address=68:D7:9A:96:2C:71 client-id=CLNLaVina11PBEM5 server=dhcp-wlan3
add address=10.64.55.78 mac-address=68:D7:9A:96:4E:37 client-id=CLNLaNozaleda40PBEM5 server=dhcp-wlan3
add address=10.64.55.79 mac-address=68:D7:9A:96:52:B6 client-id=CLNLaPride62PBEM5 server=dhcp-wlan3
add address=10.64.55.80 mac-address=FC:EC:DA:CA:00:A0 client-id=CLNLaNozaleda350PBEM5 server=dhcp-wlan3
add address=10.64.55.81 mac-address=60:22:32:D8:6D:86 client-id=CLNLaPride66PBEM5 server=dhcp-wlan3
add address=10.64.55.82 mac-address=18:E8:29:D8:EB:BC client-id=CLNLaNozaleda27PBEM5 server=dhcp-wlan3
add address=10.64.55.83 mac-address=74:AC:B9:8E:3A:24 client-id=CLNLaPride3656PBEM5 server=dhcp-wlan3
#
:delay 1
#
# Radio#: 3 CLNLaRiera-APO
/interface wireless set wlan4 name="wlan4" \
radio-name="CLNLaRiera-APO" mode=ap-bridge ssid="guifi.net-CLNLaRiera-APO" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=16 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.64.55.129/27"] do={remove $i}
/ ip address add address=10.64.55.129/27 network=10.64.55.128 broadcast=10.64.55.159 interface=wlan4 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.64.55.128/27] do={/routing bgp network remove $i;}
add network=10.64.55.128/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan4] do={/routing ospf interface remove $i;}
add interface=wlan4
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.55.128/27] do={/routing ospf network remove $i;}
add network=10.64.55.128/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan4] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan4 ranges=10.64.55.135-10.64.55.158
:foreach i in [/ip dhcp-server find name=dhcp-wlan4] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan4 interface=wlan4 address-pool=dhcp-wlan4 disabled=no
:foreach i in [/ip dhcp-server network find address="10.64.55.128/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.64.55.128/27 gateway=10.64.55.129 domain=guifi.net comment=dhcp-wlan4
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.64.55.130 mac-address=00:00:00:00:00:00 client-id=CLNLaRierabisAPO server=dhcp-wlan4
add address=10.64.55.131 mac-address=FA:BA:DA:FA:BA:DA client-id=CLNGPernusCorraliegaPBEM5 server=dhcp-wlan4
add address=10.64.55.132 mac-address=B4:FB:E4:58:4C:26 client-id=CLNBarriodePisPBEM5 server=dhcp-wlan4
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.55.0/28] do={/routing ospf network remove $i;}
add network=10.64.55.0/28 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=CLNLaRieraLaRieraTDT] do={/routing bgp peer remove $i;}
add name="CLNLaRieraLaRieraTDT" instance=default remote-address=10.64.55.3 remote-as=86177 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.55.0/28] do={/routing ospf network remove $i;}
add network=10.64.55.0/28 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=CLNLaRieraAPNE] do={/routing bgp peer remove $i;}
add name="CLNLaRieraAPNE" instance=default remote-address=10.64.55.6 remote-as=86180 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.55.0/28] do={/routing ospf network remove $i;}
add network=10.64.55.0/28 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=CLNLaRieraAPSE] do={/routing bgp peer remove $i;}
add name="CLNLaRieraAPSE" instance=default remote-address=10.64.55.7 remote-as=86181 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.55.0/28] do={/routing ospf network remove $i;}
add network=10.64.55.0/28 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=CLNLaRieraAPO] do={/routing bgp peer remove $i;}
add name="CLNLaRieraAPO" instance=default remote-address=10.64.55.9 remote-as=86183 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="10.64.55.1/28"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.64.55.1/28 network=10.64.55.0 broadcast=10.64.55.15 interface=Lan disabled=no comment="CLNLaRieraLaRieraTDT,CLNLaRieraAPNE,CLNLaRieraAPSE,CLNLaRieraAPO"
:foreach i in [/ip address find address="10.64.55.17/28"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.64.55.17/28 network=10.64.55.16 broadcast=10.64.55.31 interface=Local disabled=no comment="CLNLaRieraLaRieraTDT,CLNLaRieraAPNE,CLNLaRieraAPSE,CLNLaRieraAPO"
:foreach i in [/ip address find address="10.64.55.0/24"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.64.55.0/24 network=10.64.55.0 broadcast=10.64.55.255 interface=Reserva disabled=no comment="CLNLaRieraLaRieraTDT,CLNLaRieraAPNE,CLNLaRieraAPSE,CLNLaRieraAPO"
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.64.55.1 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.64.55.1" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.64.55.1"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=86175 router-id=10.64.55.1 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf instance set default name=default router-id=10.64.55.1 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 86175-CLNLaRiera-RB executed."
/