# Generat per a:
# RouterOSv6.x
:log info "Unsolclic for 94312-PALF-Torretes50-APNO going to be executed."
#
# Configuration for RouterOSv6.x
# Device: 94312-PALF-Torretes50-APNO
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
# a.Winbox (with Linux, wine required)
# b.Terminal (telnet, ssh...)
# Then execute the script with:
# > /system script run script_name
# 2.-Fitxer importat:
# Desa aquesta "sortida" a un fitxer, després puja'l al router
# fent servir FTP amb un nom de l'estil "script_name.rsc".
# (note, l'extensió ".rsc" es un requisit)
# Executa el fitxer importat amb la comanda:
# > /import script_name
# 3.-Telnet copia i enganxar:
# Open a terminal session, and cut&paste this output
# directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
# according in how did you connect the cable to the miniPCI. Keep the
# power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
# (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
# to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
# the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=PALF-Torretes50-APNO
#
# DNS (client & server cache) zone: 21359
/ip dns set servers=10.155.7.20,10.155.1.101 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 21359
/system ntp client set enabled=yes mode=unicast primary-ntp=10.155.7.8 secondary-ntp=10.155.1.101
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="PALF-Torretes50" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
:delay 1
#
# Radio#: 0 PALF-Torretes50-AP-NO
/interface wireless set wlan1 name="wlan1" \
radio-name="PALF-Torretes50-AP-NO" mode=ap-bridge ssid="guifi.net-PALF-Torretes50-AP-NO" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=15 \
frequency=5260 \
dfs-mode=none \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.155.7.129/27"] do={remove $i}
/ ip address add address=10.155.7.129/27 network=10.155.7.128 broadcast=10.155.7.159 interface=wlan1 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.155.7.128/27] do={/routing bgp network remove $i;}
add network=10.155.7.128/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan1] do={/routing ospf interface remove $i;}
add interface=wlan1
/ routing ospf network
:foreach i in [/routing ospf network find network=10.155.7.128/27] do={/routing ospf network remove $i;}
add network=10.155.7.128/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan1] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan1 ranges=10.155.7.135-10.155.7.158
:foreach i in [/ip dhcp-server find name=dhcp-wlan1] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan1 interface=wlan1 address-pool=dhcp-wlan1 disabled=no
:foreach i in [/ip dhcp-server network find address="10.155.7.128/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.155.7.128/27 gateway=10.155.7.129 domain=guifi.net comment=dhcp-wlan1
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.155.7.130 mac-address=00:27:22:0E:5D:FA client-id=RGNCCremany16Rd1 server=dhcp-wlan1
add address=10.155.7.131 mac-address=00:27:22:0E:84:B5 client-id=RGNCCremany18Rd1 server=dhcp-wlan1
add address=10.155.7.132 mac-address=00:27:22:1A:73:94 client-id=RGNCAmple9Rd1 server=dhcp-wlan1
add address=10.155.7.133 mac-address=00:15:6D:3C:93:4D client-id=PalfPals122Rd1 server=dhcp-wlan1
add address=10.155.7.134 mac-address=00:27:22:0E:61:E4 client-id=LlofrCHortsRd1 server=dhcp-wlan1
add address=10.155.7.135 mac-address=00:00:00:00:00:00 client-id=RGNCVellPalsRd1 server=dhcp-wlan1
add address=10.155.7.136 mac-address=00:27:22:10:BB:57 client-id=RGNCSJosepPla6Rd1 server=dhcp-wlan1
add address=10.155.7.137 mac-address=00:00:00:11:11:23 client-id=PALFEscala13BRd1 server=dhcp-wlan1
add address=10.155.7.138 mac-address=00:00:00:00:AA:AB client-id=RGNCCasesNoves21Rd1 server=dhcp-wlan1
add address=10.155.7.139 mac-address=00:00:00:00:AA:AB client-id=RGNCJosepPla5Rd1 server=dhcp-wlan1
add address=10.155.7.140 mac-address=00:27:22:10:1C:76 client-id=RGNCPonent10Rd1 server=dhcp-wlan1
add address=10.155.7.141 mac-address=00:00:00:00:AA:AB client-id=RGNCNou15Rd1 server=dhcp-wlan1
add address=10.155.7.142 mac-address=00:00:00:00:AA:AB client-id=RGNCAmple11DRd1 server=dhcp-wlan1
add address=10.155.7.143 mac-address=FF:FF:10:00:00:00 client-id=RGNCSEsglesia19Rd1 server=dhcp-wlan1
add address=10.155.7.144 mac-address=00:00:00:00:00:00 client-id=RGNCCasesNoves1Rd1 server=dhcp-wlan1
add address=10.155.7.145 mac-address=00:00:00:AA:AA:AA client-id=RGNCPuigCalent7Rd1 server=dhcp-wlan1
add address=10.155.7.146 mac-address=00:CA:00:FE:00:B1 client-id=TrrntMsBndRd1 server=dhcp-wlan1
add address=10.155.7.147 mac-address=00:AA:00:00:00:00 client-id=RGNCNou21Rd1 server=dhcp-wlan1
add address=10.155.7.148 mac-address=00:27:22:A6:46:C6 client-id=PALFPals86Rd1 server=dhcp-wlan1
add address=10.155.7.149 mac-address=00:00:00:00:00:00 client-id=RGNCSRajolers5Rd1 server=dhcp-wlan1
add address=10.155.7.150 mac-address=00:27:22:AC:6B:ED client-id=PALFHortaDeLaViolaRd1 server=dhcp-wlan1
add address=10.155.7.151 mac-address=00:00:00:00:00:00 client-id=RGNCNou3Rd1 server=dhcp-wlan1
add address=10.155.7.152 mac-address=24:A4:3C:F8:D6:6B client-id=PALFBarracaRecordsRd1 server=dhcp-wlan1
add address=10.155.7.153 mac-address=02:02:02:CA:CA:00 client-id=Esclanya1Rd1 server=dhcp-wlan1
add address=10.155.7.154 mac-address=CC:2D:E0:6A:74:9B client-id=RGNCCalTorradilloRd1 server=dhcp-wlan1
add address=10.155.7.155 mac-address=24:A4:3C:D6:76:7E client-id=RGNCSMasos32Rd1 server=dhcp-wlan1
add address=10.155.7.156 mac-address=00:00:00:00:00:00 client-id=RGNCSMasPatoxasCasaRd1 server=dhcp-wlan1
add address=10.155.7.157 mac-address=00:00:00:00:00:00 client-id=PALFGas27Rd1 server=dhcp-wlan1
add address=10.155.7.158 mac-address=00:00:00:00:00:00 client-id=RGNCAmple113Rd1 server=dhcp-wlan1
#
:delay 1
# Type: wds/p2p
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_LlfrPrtgeFalguera2Grid1" master-interface=wlan1 wds-address=00:00:00:00:00:00 disabled=no
/ ip address add address=172.25.38.54/30 network=172.25.38.52 broadcast=172.25.38.55 interface=wds_LlfrPrtgeFalguera2Grid1 disabled=no comment="wds_LlfrPrtgeFalguera2Grid1"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_LlfrPrtgeFalguera2Grid1] do={/routing ospf interface remove $i;}
add interface=wds_LlfrPrtgeFalguera2Grid1
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.38.52/30] do={/routing ospf network remove $i;}
add network=172.25.38.52/30 area=backbone disabled=no
/ routing bgp peer
:foreach i in [find name=LlfrPrtgeFalguera2Grid1] do={/routing bgp peer remove $i;}
add name="LlfrPrtgeFalguera2Grid1" instance=default remote-address=172.25.38.53 remote-as=83425 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=yes
#
:delay 1
#
# Routed device
#
# Altres connexions de cable
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.155.7.0/27] do={/routing ospf network remove $i;}
add network=10.155.7.0/27 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=PALFTorretes50ST] do={/routing bgp peer remove $i;}
add name="PALFTorretes50ST" instance=default remote-address=10.155.7.1 remote-as=94315 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="10.155.7.6/27"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.155.7.6/27 network=10.155.7.0 broadcast=10.155.7.31 interface=Lan disabled=no comment="PALFTorretes50ST"
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.155.7.6 comment="" disabled=no
#
# Enrutament BGP
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.155.7.6" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.155.7.6"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# Instància BGP
/ routing bgp instance
set default name="default" as=94312 router-id=10.155.7.6 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# Enrutament OSPF
/routing ospf instance set default name=default router-id=10.155.7.6 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 94312-PALF-Torretes50-APNO executed."
/