# Generated for:
# RouterOSv6.x
:log info "Unsolclic for 60203-Bcn-TncOmTk going to be executed."
#
# Configuration for RouterOSv6.x
# Device: 60203-Bcn-TncOmTk
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
#     a.Winbox (with Linux, wine required)
#     b.Terminal (telnet, ssh...)
#    Then execute the script with:
#      > /system script run script_name
# 2.-Imported file:
#     Save this output to a file, then upload it to the router
#     using ftp using a name like "script_name.rsc".
#     (note that extension ".rsc" is required)
#     Run the import file using the command:
#      > /import script_name
# 3.-Telnet cut&paste:
#     Open a terminal session, and cut&paste this output
#     directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
#   according in how did you connect the cable to the miniPCI. Keep the
#   power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
#   (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
#   to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
#   the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=Bcn-TncOmTk
#
# DNS (client & server cache) zone: 2436
/ip dns set servers=10.228.203.104,10.139.94.98 allow-remote-requests=yes
:delay 1
#
# NTP (client & server cache) zone: 2436
/system ntp client set enabled=yes mode=unicast primary-ntp=10.228.203.104 secondary-ntp=10.228.192.212
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="Bcn-Tnc" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
# Construct main bridge on wlan1 & ether1
/ interface bridge
add name="wLan/Lan"
/ interface bridge port
add interface=ether1 bridge=wLan/Lan
add interface=wlan1 bridge=wLan/Lan
:delay 1
#
# Radio#: 0 BCN-TNC-AP0
/interface wireless set wlan1 name="wlan1" \
radio-name="BCN-TNC-AP0" mode=ap-bridge ssid="guifi.net-BCN-TNC-AP0" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsBCN-TNC-AP0
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
#
:delay 1
# Type: wLan/Lan
/ip address
:foreach i in [find address="10.90.225.65/27"] do={remove $i}
/ ip address add address=10.90.225.65/27 network=10.90.225.64 broadcast=10.90.225.95 interface=wLan/Lan disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.90.225.64/27] do={/routing bgp network remove $i;}
add network=10.90.225.64/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wLan/Lan] do={/routing ospf interface remove $i;}
add interface=wLan/Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.90.225.64/27] do={/routing ospf network remove $i;}
add network=10.90.225.64/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wLan/Lan] do={/ip pool remove $i;}
/ip pool add name=dhcp-wLan/Lan ranges=10.90.225.71-10.90.225.94
:foreach i in [/ip dhcp-server find name=dhcp-wLan/Lan] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wLan/Lan interface=wLan/Lan address-pool=dhcp-wLan/Lan disabled=no
:foreach i in [/ip dhcp-server network find address="10.90.225.64/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.90.225.64/27 gateway=10.90.225.65 domain=guifi.net comment=dhcp-wLan/Lan
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.90.225.68 mac-address=D4:CA:6D:D2:12:5B client-id=BCNAvila149Rd1 server=dhcp-wLan/Lan
#
:delay 1
#
# Radio#: 1 Tnc-Diagonal
/interface wireless set wlan2 name="wlan2" \
radio-name="Tnc-Diagonal" mode=ap-bridge ssid="guifi.net-Tnc-Diagonal" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=16 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsTnc-M5
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan2] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_BCNlesGloriesRB750" master-interface=wlan2 wds-address=00:15:6D:8E:33:DF disabled=no
/ ip address add address=172.25.34.85/30 network=172.25.34.84 broadcast=172.25.34.87 interface=wds_BCNlesGloriesRB750 disabled=no comment="wds_BCNlesGloriesRB750"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_BCNlesGloriesRB750] do={/routing ospf interface remove $i;}
add interface=wds_BCNlesGloriesRB750
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.34.84/30] do={/routing ospf network remove $i;}
add network=172.25.34.84/30 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BCNlesGloriesRB750] do={/routing bgp peer remove $i;}
add name="BCNlesGloriesRB750" instance=default remote-address=172.25.34.86 remote-as=39840 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
#
:delay 1
#
# Radio#: 2 Tnc-Ribes
/interface wireless set wlan3 name="wlan3" \
radio-name="Tnc-Ribes" mode=ap-bridge ssid="guifi.net-Tnc-Ribes" \
band="2ghz-b" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=11 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsTnc-M2
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan3] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_BCNribes73Rb750" master-interface=wlan3 wds-address=00:00:00:00:00:00 disabled=no
/ ip address add address=172.25.44.58/30 network=172.25.44.56 broadcast=172.25.44.59 interface=wds_BCNribes73Rb750 disabled=no comment="wds_BCNribes73Rb750"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_BCNribes73Rb750] do={/routing ospf interface remove $i;}
add interface=wds_BCNribes73Rb750
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.44.56/30] do={/routing ospf network remove $i;}
add network=172.25.44.56/30 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BCNribes73Rb750] do={/routing bgp peer remove $i;}
add name="BCNribes73Rb750" instance=default remote-address=172.25.44.57 remote-as=98686 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
#
:delay 1
#
# Radio#: 3 Tnc-Casp
/interface wireless set wlan4 name="wlan4" \
radio-name="Tnc-Casp" mode=ap-bridge ssid="guifi.net-Tnc-Casp" \
band="2ghz-b" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsTnc-Casp
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan4] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_BCNcasp115750" master-interface=wlan4 wds-address=00:00:00:00:00:00 disabled=no
/ ip address add address=172.25.33.89/30 network=172.25.33.88 broadcast=172.25.33.91 interface=wds_BCNcasp115750 disabled=no comment="wds_BCNcasp115750"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_BCNcasp115750] do={/routing ospf interface remove $i;}
add interface=wds_BCNcasp115750
/ routing ospf network
:foreach i in [/routing ospf network find network=172.25.33.88/30] do={/routing ospf network remove $i;}
add network=172.25.33.88/30 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=BCNcasp115750] do={/routing bgp peer remove $i;}
add name="BCNcasp115750" instance=default remote-address=172.25.33.90 remote-as=117650 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
#
:delay 1
#
# Routed device
#
# Other cable connections
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.90.225.65 comment="" disabled=no
#
# BGP Routing
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.90.225.65" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.90.225.65"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# BGP instance
/ routing bgp instance
set default name="default" as=60203 router-id=10.90.225.65 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# OSPF Routing
/routing ospf instance set default name=default router-id=10.90.225.65 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 60203-Bcn-TncOmTk executed."
/