# Generated for:
# RouterOSv6.x
:log info "Unsolclic for 116016-CUDResiellas-RB going to be executed."
#
# Configuration for RouterOSv6.x
# Device: 116016-CUDResiellas-RB
#
# Methods to upload/execute this script:
# 1.-As a script. Upload this output as a script either with:
#     a.Winbox (with Linux, wine required)
#     b.Terminal (telnet, ssh...)
#    Then execute the script with:
#      > /system script run script_name
# 2.-Imported file:
#     Save this output to a file, then upload it to the router
#     using ftp using a name like "script_name.rsc".
#     (note that extension ".rsc" is required)
#     Run the import file using the command:
#      > /import script_name
# 3.-Telnet cut&paste:
#     Open a terminal session, and cut&paste this output
#     directly on the terminal input.
#
# Notes:
# -routing-test package is required if you use RouterOSv2.9 , be sure you have it enabled at system packages
# -wlans should be enabled manually, be sure to set the correct antenna (a or b)
#   according in how did you connect the cable to the miniPCI. Keep the
#   power at the minimum possible and check the channel.
# -The script doesn't reset the router, you might have to do it manually
# -You must have write access to the router
# -MAC access (winbox, MAC telnet...) method is recommended
#   (the script reconfigures some IP addresses, so communication can be lost)
# -No changes are done in user passwords on the device
# -A Read Only guest account with no password will be created to allow guest access
#   to the router with no danger of damage but able to see the config.
# -Be sure that all packages are activated.
# -Don't run the script from telnet and being connected through an IP connection at
#   the wLan/Lan interface: This interface will be destroyed during the script.
#
/ system identity set name=CUDResiellas-RB
#
# DNS (client & server cache) zone: 132158
:delay 1
#
# NTP (client & server cache) zone: 132158
:delay 1
#
# Bandwidth-server
/ tool bandwidth-server set enabled=yes authenticate=no allocate-udp-ports-from=2000
#
# SNMP
/snmp community set public addresses=10.0.0.0/8
/snmp set contact="guifi@guifi.net" enabled=yes location="CUDResiellas" trap-community=public
#
# Guest user
/user
:foreach i in [find group=read] do={/user remove $i;}
add name="guest" group=read address=10.0.0.0/8 comment="" disabled=no
#
# Graphing
/tool graphing interface add
# Remove current wLan/Lan bridge if exists
:foreach i in [/interface bridge find name=wLan/Lan] \
do={:foreach i in [/interface bridge port find bridge=wLan/Lan] \
do={/interface bridge port remove $i; \
:foreach i in [/ip address find interface=wLan/Lan] \
do={/ip address remove $i;};};
/interface bridge remove $i;}
:delay 1
#
# Radio#: 0 CUDResiellas-Cadavedo
/interface wireless set wlan1 name="wlan1" \
radio-name="CUDResiellas-Cadavedo" mode=ap-bridge ssid="guifi.net-CUDResiellas-Cadavedo" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wdsCUDResiellas-Cadavedo
# Remove all existing wds interfaces
:foreach i in [/interface wireless wds find master-interface=wlan1] \
do={:foreach n in [/interface wireless wds get $i name] \
do={:foreach inum in [/ip address find interface=$n] \
do={/ip address remove $inum;};}; \
/interface wireless wds remove $i;}
/ interface wireless wds
add name="wds_VDSCadavedoRB" master-interface=wlan1 wds-address=00:00:00:00:00:00 disabled=no
/ ip address add address=172.16.21.14/30 network=172.16.21.12 broadcast=172.16.21.15 interface=wds_VDSCadavedoRB disabled=no comment="wds_VDSCadavedoRB"
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wds_VDSCadavedoRB] do={/routing ospf interface remove $i;}
add interface=wds_VDSCadavedoRB
/ routing ospf network
:foreach i in [/routing ospf network find network=172.16.21.12/30] do={/routing ospf network remove $i;}
add network=172.16.21.12/30 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=VDSCadavedoRB] do={/routing bgp peer remove $i;}
add name="VDSCadavedoRB" instance=default remote-address=172.16.21.13 remote-as=115879 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
#
:delay 1
#
# Radio#: 1 CUDResiellas-APNE
/interface wireless set wlan2 name="wlan2" \
radio-name="CUDResiellas-APNE" mode=ap-bridge ssid="guifi.net-CUDResiellas-APNE" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.64.95.33/27"] do={remove $i}
/ ip address add address=10.64.95.33/27 network=10.64.95.32 broadcast=10.64.95.63 interface=wlan2 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.64.95.32/27] do={/routing bgp network remove $i;}
add network=10.64.95.32/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan2] do={/routing ospf interface remove $i;}
add interface=wlan2
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.95.32/27] do={/routing ospf network remove $i;}
add network=10.64.95.32/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan2] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan2 ranges=10.64.95.39-10.64.95.62
:foreach i in [/ip dhcp-server find name=dhcp-wlan2] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan2 interface=wlan2 address-pool=dhcp-wlan2 disabled=no
:foreach i in [/ip dhcp-server network find address="10.64.95.32/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.64.95.32/27 gateway=10.64.95.33 domain=guifi.net comment=dhcp-wlan2
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.64.95.34 mac-address=00:00:00:00:00:00 client-id=CUDResiellasbisAPNE server=dhcp-wlan2
add address=10.64.95.35 mac-address=24:5A:4C:C4:DF:FB client-id=CUDValdredo3037LBAC server=dhcp-wlan2
add address=10.64.95.36 mac-address=F4:E2:C6:34:28:BF client-id=CUDCamindelaEra374LBAC server=dhcp-wlan2
add address=10.64.95.37 mac-address=F4:E2:C6:34:85:0F client-id=CUDCamindelaHera654LBAC server=dhcp-wlan2
#
:delay 1
#
# Radio#: 2 CUDResiellas-APO
/interface wireless set wlan3 name="wlan3" \
radio-name="CUDResiellas-APO" mode=ap-bridge ssid="guifi.net-CUDResiellas-APO" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.64.95.65/27"] do={remove $i}
/ ip address add address=10.64.95.65/27 network=10.64.95.64 broadcast=10.64.95.95 interface=wlan3 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.64.95.64/27] do={/routing bgp network remove $i;}
add network=10.64.95.64/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan3] do={/routing ospf interface remove $i;}
add interface=wlan3
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.95.64/27] do={/routing ospf network remove $i;}
add network=10.64.95.64/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan3] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan3 ranges=10.64.95.71-10.64.95.94
:foreach i in [/ip dhcp-server find name=dhcp-wlan3] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan3 interface=wlan3 address-pool=dhcp-wlan3 disabled=no
:foreach i in [/ip dhcp-server network find address="10.64.95.64/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.64.95.64/27 gateway=10.64.95.65 domain=guifi.net comment=dhcp-wlan3
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.64.95.66 mac-address=00:00:00:00:00:00 client-id=CUDResiellasbisAPO server=dhcp-wlan3
add address=10.64.95.67 mac-address=24:5A:4C:C0:82:1C client-id=VDSRibon3024LBAC server=dhcp-wlan3
add address=10.64.95.68 mac-address=24:5A:4C:C4:E2:90 client-id=CUDCaleadeAbajo113LBAC server=dhcp-wlan3
add address=10.64.95.69 mac-address=68:D7:9A:90:1F:2E client-id=VDSCasaMarioSCLBAC server=dhcp-wlan3
add address=10.64.95.70 mac-address=68:D7:9A:90:5D:A9 client-id=VDSCaminoMiares246LBAC server=dhcp-wlan3
#
:delay 1
#
# Radio#: 3 CUDResiellas-CAROYAS-E
/interface wireless set wlan4 name="wlan4" \
radio-name="CUDResiellas-CAROYAS-E" mode=ap-bridge ssid="guifi.net-CUDResiellas-CAROYAS-E" \
band="5ghz-a" channel-width=20mhz \
frequency-mode=regulatory-domain country=spain antenna-gain=14 \
dfs-mode=radar-detect \
antenna-mode=ant-a wds-mode=static wds-default-bridge=none wds-default-cost=100 \
wds-cost-range=50-150 wds-ignore-ssid=yes hide-ssid=no
:delay 1
# Type: wLan
/ip address
:foreach i in [find address="10.64.95.97/27"] do={remove $i}
/ ip address add address=10.64.95.97/27 network=10.64.95.96 broadcast=10.64.95.127 interface=wlan4 disabled=no
/ routing bgp network
:foreach i in [/routing bgp network find network=10.64.95.96/27] do={/routing bgp network remove $i;}
add network=10.64.95.96/27 synchronize=no disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=wlan4] do={/routing ospf interface remove $i;}
add interface=wlan4
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.95.96/27] do={/routing ospf network remove $i;}
add network=10.64.95.96/27 area=backbone disabled=no
:delay 1
#
# DHCP
:foreach i in [/ip pool find name=dhcp-wlan4] do={/ip pool remove $i;}
/ip pool add name=dhcp-wlan4 ranges=10.64.95.103-10.64.95.126
:foreach i in [/ip dhcp-server find name=dhcp-wlan4] do={/ip dhcp-server remove $i;}
/ip dhcp-server add name=dhcp-wlan4 interface=wlan4 address-pool=dhcp-wlan4 disabled=no
:foreach i in [/ip dhcp-server network find address="10.64.95.96/27"] do={/ip dhcp-server network remove $i;}
/ip dhcp-server network add address=10.64.95.96/27 gateway=10.64.95.97 domain=guifi.net comment=dhcp-wlan4
/ip dhcp-server lease
:foreach i in [find comment=""] do={remove $i;}
:delay 1
add address=10.64.95.98 mac-address=00:00:00:00:00:00 client-id=CUDResiellasCaroyas server=dhcp-wlan4
add address=10.64.95.99 mac-address=00:00:00:00:00:00 client-id=VDSCaroyasResiellas server=dhcp-wlan4
add address=10.64.95.100 mac-address=00:00:00:00:00:00 client-id=VDSCaroyasSW server=dhcp-wlan4
add address=10.64.95.101 mac-address=00:00:00:00:00:00 client-id=VDSCaroyasAPE server=dhcp-wlan4
add address=10.64.95.102 mac-address=24:5A:4C:44:0C:FB client-id=VDSElBarreiro3100LBAC server=dhcp-wlan4
add address=10.64.95.103 mac-address=74:AC:B9:76:FB:8E client-id=VDSCaroyasCasaNuevaLBAC server=dhcp-wlan4
add address=10.64.95.104 mac-address=FC:EC:DA:5C:7D:D5 client-id=VDSCaroyas1672PBEM5 server=dhcp-wlan4
add address=10.64.95.105 mac-address=E0:63:DA:4A:E7:0E client-id=VDSCaroyas1912LBAC server=dhcp-wlan4
add address=10.64.95.106 mac-address=24:5A:4C:44:10:3C client-id=VDSCueva3261LBAC server=dhcp-wlan4
add address=10.64.95.107 mac-address=24:5A:4C:44:4B:05 client-id=VDSCasaCurroLBAC server=dhcp-wlan4
add address=10.64.95.108 mac-address=E4:38:83:B8:C1:E9 client-id=VDSLaPlayaKabaniaLBAC server=dhcp-wlan4
add address=10.64.95.109 mac-address=24:5A:4C:42:F1:54 client-id=VDSCueva3332LBAC server=dhcp-wlan4
add address=10.64.95.110 mac-address=24:5A:4C:44:4C:3B client-id=VDSCueva2LBAC server=dhcp-wlan4
add address=10.64.95.111 mac-address=24:5A:4C:CC:4D:64 client-id=VDSCaroyas3455LBAC server=dhcp-wlan4
add address=10.64.95.112 mac-address=E4:38:83:B8:C2:1E client-id=VDSCueva3LBAC server=dhcp-wlan4
add address=10.64.95.113 mac-address=9C:05:D6:8C:E7:EC client-id=VDSBarriodeAbajo3831LBAC server=dhcp-wlan4
#
:delay 1
#
# Routed device
#
# Other cable connections
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.95.0/28] do={/routing ospf network remove $i;}
add network=10.64.95.0/28 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=CUDResiellasAPO] do={/routing bgp peer remove $i;}
add name="CUDResiellasAPO" instance=default remote-address=10.64.95.7 remote-as=116019 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.95.0/28] do={/routing ospf network remove $i;}
add network=10.64.95.0/28 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=CUDResiellasCadavedo] do={/routing bgp peer remove $i;}
add name="CUDResiellasCadavedo" instance=default remote-address=10.64.95.2 remote-as=116017 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.95.0/28] do={/routing ospf network remove $i;}
add network=10.64.95.0/28 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=CUDResiellasAPNE] do={/routing bgp peer remove $i;}
add name="CUDResiellasAPNE" instance=default remote-address=10.64.95.6 remote-as=116018 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
/ routing ospf interface
:foreach i in [/routing ospf interface find interface=Lan] do={/routing ospf interface remove $i;}
add interface=Lan
/ routing ospf network
:foreach i in [/routing ospf network find network=10.64.95.0/28] do={/routing ospf network remove $i;}
add network=10.64.95.0/28 area=backbone disabled=yes
/ routing bgp peer
:foreach i in [find name=CUDResiellasCAROYASAPE] do={/routing bgp peer remove $i;}
add name="CUDResiellasCAROYASAPE" instance=default remote-address=10.64.95.8 remote-as=116824 \
multihop=no route-reflect=no ttl=default in-filter=ebgp-in out-filter=ebgp-out disabled=no
:foreach i in [/ip address find address="10.64.95.1/28"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.64.95.1/28 network=10.64.95.0 broadcast=10.64.95.15 interface=Lan disabled=no comment="CUDResiellasAPO,CUDResiellasCadavedo,CUDResiellasAPNE,CUDResiellasCAROYASAPE"
:foreach i in [/ip address find address="10.64.95.17/28"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.64.95.17/28 network=10.64.95.16 broadcast=10.64.95.31 interface=Local disabled=no comment="CUDResiellasAPO,CUDResiellasCadavedo,CUDResiellasAPNE,CUDResiellasCAROYASAPE"
:foreach i in [/ip address find address="10.64.95.0/24"] do={/ip address remove $i;}
:delay 1
/ ip address add address=10.64.95.0/24 network=10.64.95.0 broadcast=10.64.95.255 interface=Reserva disabled=no comment="CUDResiellasAPO,CUDResiellasCadavedo,CUDResiellasAPNE,CUDResiellasCAROYASAPE"
#
# Internal addresses NAT
:foreach i in [/ip firewall nat find src-address="172.16.0.0/12"] do={/ip firewall nat remove $i;}
:foreach i in [/ip firewall nat find src-address="192.168.0.0/16"] do={/ip firewall nat remove $i;}
/ip firewall nat
add chain=srcnat src-address="192.168.0.0/16" dst-address=!192.168.0.0/16 action=src-nat to-addresses=10.64.95.1 comment="" disabled=no
#
# BGP Routing
# BGP & OSPF Filters
:foreach i in [/routing filter find chain=ospf-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ospf-out] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-in] do={/routing filter remove $i;}
:foreach i in [/routing filter find chain=ebgp-out] do={/routing filter remove $i;}
/ routing filter
add chain=ebgp-in comment="0. Set ebgp-in preferred source." set-pref-src="10.64.95.1" disabled=no
add action=discard chain=ebgp-in comment="1. Discard insert non 10.x routes from BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=discard chain=ebgp-out comment="2. Discard send non 10.x routes to BGP peer" disabled=no invert-match=no prefix=!10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-in comment="3. Accept insert 10.x routes from OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32 set-pref-src="10.64.95.1"
add action=accept chain=ospf-in comment="4. Accept insert 172.x routes from OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-in comment="5. Discard insert non 10.x and 172.x from OSPF neighbor" disabled=no invert-match=no
add action=accept chain=ospf-out comment="6. Allow send 10.x routes to OSPF neighbor" disabled=no invert-match=no prefix=10.0.0.0/8 prefix-length=8-32
add action=accept chain=ospf-out comment="7. Allow send 172.x routes to OSPF neighbor" disabled=no invert-match=no prefix=172.16.0.0/12 prefix-length=8-32
add action=discard chain=ospf-out comment="8. Discard send non 10.x and 172.x to OSPF neighbor" disabled=no invert-match=no
#
# BGP instance
/ routing bgp instance
set default name="default" as=116016 router-id=10.64.95.1 \
redistribute-connected=no redistribute-static=no redistribute-rip=no \
redistribute-ospf=yes redistribute-other-bgp=yes out-filter=ebgp-out \
client-to-client-reflection=yes comment="" disabled=no
#
# OSPF Routing
/routing ospf instance set default name=default router-id=10.64.95.1 comment="" disabled=no distribute-default=never \
redistribute-bgp=as-type-1 redistribute-connected=no redistribute-other-ospf=no redistribute-rip=no redistribute-static=no in-filter=ospf-in out-filter=ospf-out
#
:log info "Unsolclic for 116016-CUDResiellas-RB executed."
/